Last Comment Bug 710331 - UX for bookmarks and history import
: UX for bookmarks and history import
Status: VERIFIED FIXED
: uiwanted
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: Firefox 12
Assigned To: Gian-Carlo Pascutto [:gcp]
:
Mentors:
Depends on: 710330
Blocks: 713283
  Show dependency treegraph
 
Reported: 2011-12-13 12:06 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-10-17 02:43 PDT (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
splash screen (518.78 KB, image/png)
2012-01-16 10:14 PST, Ian Barlow (:ibarlow)
no flags Details
Specs for splash screen (171.07 KB, image/png)
2012-01-18 08:28 PST, Ian Barlow (:ibarlow)
no flags Details
Patch 1. Code for the Setting up screen uX (12.02 KB, patch)
2012-01-23 04:23 PST, Gian-Carlo Pascutto [:gcp]
mark.finkle: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Review
Patch 2. Remove unused splash screen assets (3.28 KB, patch)
2012-01-23 05:47 PST, Gian-Carlo Pascutto [:gcp]
gpascutto: review+
blassey.bugs: approval‑mozilla‑aurora+
Details | Diff | Review

Description Brad Lassey [:blassey] (use needinfo?) 2011-12-13 12:06:57 PST

    
Comment 1 Madhava Enros [:madhava] 2012-01-05 09:22:07 PST
Is this about a UI for importing bookmarks and history from the native browser?

Or is this about getting bookmarks/history in from an existing version of XUL Fennec? So for the user who is "updating" to Fx11, they have all their stuff?
Comment 2 Madhava Enros [:madhava] 2012-01-05 09:31:55 PST
Oh, bug 710330 blocking this one gives me a clue.
Comment 3 Madhava Enros [:madhava] 2012-01-05 09:37:42 PST
Simplest idea of all -- we could do a splashscreen that says "Setting Up Firefox" (as we used to) to give people an idea that this is a one time thing.

CCing in Matej and Martell to see if there's anything from brand that we'd want to use to amuse or communicate to people about while we're at it.
Comment 4 Matej Novak [:matej] 2012-01-05 11:22:12 PST
As much as I love injecting personality into the product where possible, I think this might a time where we just want to be short, sweet and really clear. +1 to "Setting Up Firefox" (unless we want to add something like "...for maximum awesomeness," but that's not going to be very l10n friendly).
Comment 5 Madhava Enros [:madhava] 2012-01-05 12:08:30 PST
So lazy. By which I mean thank you for your considered opinion. :)

OK - simple and straightforward it is.
Comment 6 Ian Barlow (:ibarlow) 2012-01-16 10:14:40 PST
Created attachment 588925 [details]
splash screen

just nice and simple. I'll post some logo assets soon. 

(the background is the same that is used in the tab menu, and the spinner is just the normal spinner)
Comment 7 Ian Barlow (:ibarlow) 2012-01-18 08:28:34 PST
Created attachment 589522 [details]
Specs for splash screen
Comment 8 Ian Barlow (:ibarlow) 2012-01-18 08:33:55 PST
Here's a link to the logo assets http://dl.dropbox.com/u/2182500/Mozilla/splash-screen-logos.zip

This should be ready for implementation now
Comment 9 Axel Hecht [:Pike] 2012-01-20 03:55:24 PST
This smells like it's adding a string?
Comment 10 Gian-Carlo Pascutto [:gcp] 2012-01-23 03:49:52 PST
It's not, we can reuse R.string.splash_firstrun.
Comment 11 Gian-Carlo Pascutto [:gcp] 2012-01-23 04:23:21 PST
Created attachment 590673 [details] [diff] [review]
Patch 1. Code for the Setting up screen uX

Implementation of the described UX. I will actually use this for bug 713283, as far as I understand the UX experience there should be identical to this one.

It will delay displaying itself by 100ms to avoid flicker if the operations complete very quickly.

I noticed 
 mobile/android/branding/*/content/splash.png
 mobile/android/branding/*/content/splash_v9.9.png
 mobile/android/branding/*/content/splash_v8.9.png
which we probably don't actually use in Native Fennec? We can probably remove them then?
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-23 04:42:59 PST
Comment on attachment 590673 [details] [diff] [review]
Patch 1. Code for the Setting up screen uX

Looks good, and yes we can remove the "splash" assets from native fennec.
Comment 13 Gian-Carlo Pascutto [:gcp] 2012-01-23 05:47:53 PST
Created attachment 590683 [details] [diff] [review]
Patch 2. Remove unused splash screen assets
Comment 14 Sriram Ramasubramanian [:sriram] 2012-01-25 10:04:33 PST
Some of the initializations are done in onCreate(). I feel those can be specified in XML file instead. It is costly to assign in java usually.
Comment 16 Gian-Carlo Pascutto [:gcp] 2012-01-26 00:43:24 PST
Comment on attachment 590683 [details] [diff] [review]
Patch 2. Remove unused splash screen assets

[Approval Request Comment]
Required for improve profile migration.
Comment 19 Brad Lassey [:blassey] (use needinfo?) 2012-01-27 11:40:29 PST
Comment on attachment 590673 [details] [diff] [review]
Patch 1. Code for the Setting up screen uX

this already landed because of a miscommunication over irc, giving it approval post-landing
Comment 20 Brad Lassey [:blassey] (use needinfo?) 2012-01-27 11:40:58 PST
Comment on attachment 590683 [details] [diff] [review]
Patch 2. Remove unused splash screen assets

this already landed because of a miscommunication over irc, giving it approval post-landing
Comment 21 Gian-Carlo Pascutto [:gcp] 2012-02-09 13:12:45 PST
If possible, I'd like to ask we reconsider this UX. While we'll do what we can to keep migration times <1 minute, that's still fairly long. Secondly, for users with large numbers of bookmarks (more than a few hundred), or slow phones (specially if we get ARMv6 in), we can't really predict how long they are going to see this screen, but it might be considerably longer.

The experience would probably be improved if we can show, instead of "Setting up Firefox...":

1) Importing bookmarks: x out of y
2) Importing history: x out of y
3) Importing favicons: x out of y
[4) Importing passwords: x out of y]  <- we don't do this yet

This:
a) Informs the user what is actually happening.
b) Will show progress, removing the impression the browser is stuck here forever.
c) Helps understand that this is really a one-time event on first start.
d) Alerts the user that it restarts if they close Fennec (either directly or by exiting and starting many other apps).

I know l10n will be thrilled by the idea of new strings, but I figure I'd rather bring this up now (and maybe not need it in the end if we can get the migration fast enough), rather than leave it be and panic at the last minute when we see some users with tons of bookmarks are getting a terrible experience.

Maybe we can do:
line1: Setting up Fennec...
line2: Bookmarks (x/y)

The new string impact of that should be small or nonexistent (might not have a string for favicons yet).
Comment 22 Robert Kaiser (not working on stability any more) 2012-02-10 04:24:15 PST
I agree with gcp here - we've taken enough beating from XUL version users on the startup logo screen, we even heard statements like "I hate this Firefox logo". When we do something similar on the first startup, which is the first impression we make on the user, then this is quite bad. If we tell the user explicitely what they need to wait for, this impression will hopefully be totally different.
Comment 23 Madhava Enros [:madhava] 2012-02-22 07:43:57 PST
Let's open a new bug for UX improvements here. I think we need to find a compromise between:

- reducing the overall time required
- making the time we can't cut less visible (i.e. on demand; hidden while something else is happening; other)
- where we can't hide it, distracting the user more (i.e. progress, or having some other conversation with them)
- making it clear that this is a one time thing

Just providing more detail isn't necessarily going to make for a better experience.

I opened Bug 729532 - Improve first-run profile import experience
Comment 24 Cristian Nicolae (:xti) 2012-10-17 02:43:56 PDT
UI updates when importing bookmarks and history were already landed since some versions ago. Closing bug as verified fixed.

Note You need to log in before you can comment on or make changes to this bug.