Last Comment Bug 710335 - about:home - add UI for when there are no thumbnails or no addons
: about:home - add UI for when there are no thumbnails or no addons
Status: RESOLVED FIXED
[QA?]
: uiwanted
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: Firefox 13
Assigned To: Lucas Rocha (:lucasr)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-13 12:10 PST by Lucas Rocha (:lucasr)
Modified: 2016-07-29 14:21 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed
11+


Attachments
Mockup of start page empty states (715.38 KB, image/png)
2012-01-16 08:38 PST, Ian Barlow (:ibarlow)
no flags Details
Hide recommended addons section from about:home when empty (4.19 KB, patch)
2012-01-31 10:50 PST, Lucas Rocha (:lucasr)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Splinter Review

Description Lucas Rocha (:lucasr) 2011-12-13 12:10:10 PST
We should show a message when that happens. Ian had design for that I think.
Comment 1 Ian Barlow (:ibarlow) 2012-01-16 08:38:25 PST
Created attachment 588893 [details]
Mockup of start page empty states

If no top sites are found:
"You do not have any top sites.
Tap the Title Bar to start browsing."

If no add-ons are found:
"No available add-ons"
Comment 2 Lucas Rocha (:lucasr) 2012-01-18 11:08:08 PST
Working on a patch for this one.
Comment 3 Axel Hecht [:Pike] 2012-01-20 03:56:58 PST
This sounds like new strings to me?
Comment 4 Lucas Rocha (:lucasr) 2012-01-20 03:58:47 PST
(In reply to Axel Hecht [:Pike] from comment #3)
> This sounds like new strings to me?

Yes.
Comment 5 Axel Hecht [:Pike] 2012-01-30 07:43:39 PST
Brad, Mark, is this still 11 material?
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-30 08:51:58 PST
(In reply to Axel Hecht [:Pike] from comment #5)
> Brad, Mark, is this still 11 material?

It's possible. I don't think this is truly a P2 though.
Comment 7 Lucas Rocha (:lucasr) 2012-01-30 08:58:46 PST
The thumbnails part has already been done in bug 708414. It should be simple to implement the addons part. Ian, Madhava, do you prefer the whole section to be hidden when there are no recommended addons? Or is it still the case to show a message?
Comment 8 Ian Barlow (:ibarlow) 2012-01-30 12:13:36 PST
Lucas, after thinking about it a little more I think we should hide add-ons completely if there isn't anything to show. 

Showing an empty state for Top Sites is more useful, as quick access to your stuff is a primary purpose for this start page. Since Add-ons are somewhat lower in importance here, I don't think people will miss anything if we aren't telling them we don't have anything to show them ;)
Comment 9 Axel Hecht [:Pike] 2012-01-30 13:32:06 PST
Confirmed on irc, Ian says we don't need more strings for this bug. Removing late-l10n keyword.
Comment 10 Lucas Rocha (:lucasr) 2012-01-31 10:50:03 PST
Created attachment 593159 [details] [diff] [review]
Hide recommended addons section from about:home when empty
Comment 11 Lucas Rocha (:lucasr) 2012-02-02 07:58:51 PST
Pushed: http://hg.mozilla.org/integration/mozilla-inbound/rev/63f719f6681b
Comment 12 Lucas Rocha (:lucasr) 2012-02-02 07:59:48 PST
Comment on attachment 593159 [details] [diff] [review]
Hide recommended addons section from about:home when empty

Non-risky. Fixes broken visual on about:home when there are no addons to recommend.
Comment 13 Ed Morley [:emorley] 2012-02-03 11:40:57 PST
https://hg.mozilla.org/mozilla-central/rev/63f719f6681b
Comment 14 Alex Keybl [:akeybl] 2012-02-05 13:37:10 PST
Comment on attachment 593159 [details] [diff] [review]
Hide recommended addons section from about:home when empty

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 15 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 12:28:41 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/53b837964a4b
Comment 16 Brad Lassey [:blassey] (use needinfo?) 2012-02-06 13:59:26 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/5e2e576fa0e0
Comment 17 Camelia Urian 2012-02-07 07:26:36 PST
Nightly 13.0a1 (2012-02-07)
Aurora 12.0a2 (2012-02-07)
Beta 11.0 (20120206202409 - http://hg.mozilla.org/releases/mozilla-beta/rev/1c0aba74d116)
Device: Samsung Google Nexus S - Android 2.3.6


UI for no thumbnails on start page is correctly displayed(as in attachment from comment 1), but how do you verify no addons. I tried starting Fennec with a clear profile and no internet internet connection, but 2 addons: Cleary and Clear Mobile History are always displayed
Comment 18 Aaron Train [:aaronmt] 2012-02-07 07:36:00 PST
Those are duds. I have no idea if and when they will be hooked up.

Note You need to log in before you can comment on or make changes to this bug.