Auto-updated extensions don't trigger restart main reminder

RESOLVED DUPLICATE of bug 553460

Status

()

Toolkit
Add-ons Manager
RESOLVED DUPLICATE of bug 553460
7 years ago
6 years ago

People

(Reporter: Will Pittenger, Unassigned)

Tracking

8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 581553 [details]
Screen-cap showing the problem

User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I have the ABP dev build installed.  As you might know, they have been updating their dev build frequently for the past week or so.  A few times I noticed that Firefox 8.0 (32-bit on 64-bit Vista SP2) updated ABP automatically.  That would be fine.  Expect for one thing.  As shown in the scren-cap, the restart reminder on top was missing.  If ABP hadn't been right there, I might not have known there was an update even though I check about:addons several times a day.


Actual results:

After automatically updating ABP's dev build, Firefox failed to put the main "Restart Now" link on the top part of about:addons.


Expected results:

Any time addons are updated that require a restart, regardless of how the application found it needed to update those extensions, about:addons should display the main "Restart Now" link.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553460
Duplicate of this bug: 734354
You need to log in before you can comment on or make changes to this bug.