Last Comment Bug 710578 - Can't load chrome pages
: Can't load chrome pages
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P1 normal (vote)
: ---
Assigned To: Matt Brubeck (:mbrubeck)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 03:05 PST by Doug Turner (:dougt)
Modified: 2012-01-09 12:12 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (1.24 KB, patch)
2011-12-14 12:14 PST, Matt Brubeck (:mbrubeck)
mark.finkle: review+
Details | Diff | Splinter Review

Description Doug Turner (:dougt) 2011-12-14 03:05:51 PST
in browser.js, onLocationChange().  chrome pages do not have contentDocuments.  so we end up passing undefined to java.  This, in turn, causes an exception to be raised when handling the Content:LocationChange message.


E/GeckoApp(28356): org.json.JSONException: No value for documentURI                                                                                                    
E/GeckoApp(28356):      at org.json.JSONObject.get(JSONObject.java:354)                                                                                                
E/GeckoApp(28356):      at org.json.JSONObject.getString(JSONObject.java:510)                                                                                          
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoApp.handleMessage(GeckoApp.java:860)                                                                                 
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoAppShell.handleGeckoMessage(GeckoAppShell.java:1501)                                                                 
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)                                                                                    
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)                                                                                    
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:447)                                                                            
E/GeckoApp(28356):      at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)                                                                                     
I/GeckoApp(28356): Got message: Content:SecurityChange
Comment 1 Matt Brubeck (:mbrubeck) 2011-12-14 12:14:23 PST
Created attachment 581744 [details] [diff] [review]
patch

This should fix the problem, but I wasn't able to verify the fix because I couldn't reproduce the error.

Doug, what steps did you use to produce this?  I tried loading chrome://browser/content/about.xhtml but I did not see any errors or bugs.
Comment 2 Doug Turner (:dougt) 2011-12-14 12:50:17 PST
try loading about:config
Comment 3 Matt Brubeck (:mbrubeck) 2011-12-14 13:08:32 PST
(In reply to Doug Turner (:dougt) from comment #2)
> try loading about:config

about:config loads fine for me in today's native android nightly (build ID 20111214, built from 221eccfa6a3f).  I didn't see any exceptions or errors logcat.
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-14 13:38:43 PST
pushed https://hg.mozilla.org/mozilla-central/rev/5ef118dcf1a1
Comment 5 Catalin Suciu [:csuciu] 2011-12-20 06:42:47 PST
I cannot reproduce this on the latest native fennec:
Mozilla/5.0(Android;Linux armv7l;rv:11.0a1)Gecko/20111220;Firefox/11.0a1 Fennec/11.0a1.
Device: HTC Desire (Android 2.2)

Note You need to log in before you can comment on or make changes to this bug.