Last Comment Bug 710703 - "Enable Flash" text is confusing
: "Enable Flash" text is confusing
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: ---
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-14 07:25 PST by Aaron Train [:aaronmt]
Modified: 2012-01-09 11:50 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (8.06 KB, patch)
2011-12-19 11:29 PST, :Margaret Leibovic
mark.finkle: review+
Details | Diff | Splinter Review

Description Aaron Train [:aaronmt] 2011-12-14 07:25:41 PST
http://hg.mozilla.org/mozilla-central/rev/41ceaff2e5f1 form bug 702653 landed the string, "Enable Flash" (pref_enable_flash). My device by default (Nexus S) currently does not have Flash installed. It is confusing to see Flash enabled yet it is not installed.

Stock browser has "Enable plug-ins"

--
Samsung Nexus S (Android 2.3.6)
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a1) Gecko/20111214 Firefox/11.0a1 Fennec/11.0a1
Comment 1 Doug Turner (:dougt) 2011-12-14 07:31:41 PST
lets not dictate solutions.  adjusting summary.

brad|snorp - maybe we can disable this option if we don't detect flash?
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-14 07:41:07 PST
(In reply to Doug Turner (:dougt) from comment #1)

> brad|snorp - maybe we can disable this option if we don't detect flash?

Not worth the effort IMO. Let's just change the text. Madhava?
Comment 3 :Margaret Leibovic 2011-12-14 09:27:32 PST
In actuality, the pref enables/disables/tap to play-s all plugins, not just flash. I think we just used flash in the strings because that's the only plugin we have right now. We also use the word Flash in the doorhanger message. Should we change that as well?
Comment 4 Ian Barlow (:ibarlow) 2011-12-19 11:05:41 PST
Madhava is on vacation, so in his absence I agree we should change the text to 

"Enable Plugins"

(note no hyphenation)

And Margaret, we should probably change it in the doorhangers for consistency's sake as well.
Comment 5 :Margaret Leibovic 2011-12-19 11:29:52 PST
Created attachment 582897 [details] [diff] [review]
patch

I changed all the string entity names as well to reduce confusion in the future.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-19 11:34:25 PST
Comment on attachment 582897 [details] [diff] [review]
patch

looks good
Comment 8 Ed Morley [:emorley] 2011-12-20 06:07:08 PST
https://hg.mozilla.org/mozilla-central/rev/f2935a9c0ffc
Comment 9 Catalin Suciu [:csuciu] 2011-12-21 22:05:39 PST
Verified fixed on Mozilla/5.0(Android;Linux armv7l;rv:12.0a1)Gecko/20111221;Firefox/12.0a1 Fennec/12.0a1.
Device: HTC Desire (Android 2.2)
Comment 10 Brad Lassey [:blassey] (use needinfo?) 2012-01-09 11:50:56 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/f2935a9c0ffc

Note You need to log in before you can comment on or make changes to this bug.