If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Moves of multiple messages not atomic, becoming partial copies, for example if disk is full

RESOLVED DUPLICATE of bug 195077

Status

MailNews Core
Database
--
critical
RESOLVED DUPLICATE of bug 195077
6 years ago
4 years ago

People

(Reporter: Nim Delineif, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

6 years ago
1) Create in the inbox the following messages:
A 2Kb
B 2Kb
C 3Mb
D 2Kb

2) Fill the disk leaving just 2Mb free

3) Move the above messages to another folder (eg. Sent)

4) Thunderbird shows a message saying there wasn't enough space to move them

5) The state is now this:
Inbox: A B C D
Sent: A B

(messages became duplicated)

Given that the desired state is unreachable, it should be left in either:
Inbox: A B C D
Sent:

or

Inbox: C D
Sent: A B 

Note that even a check for free space before actually doing anything would help. It could still happen, but would need a race condition.
Severity: normal → critical
Keywords: dataloss
Summary: Moves of multiple messages not atomic, becoming partial copies → Moves of multiple messages not atomic, becoming partial copies, for example if disk is full
Whiteboard: [dupeme]
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 195077
You need to log in before you can comment on or make changes to this bug.