Last Comment Bug 710885 - In some cases tapping to activate Flash does not activate Flash
: In some cases tapping to activate Flash does not activate Flash
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P2 normal (vote)
: Firefox 12
Assigned To: :Margaret Leibovic
:
Mentors:
Depends on:
Blocks: 713914
  Show dependency treegraph
 
Reported: 2011-12-14 14:01 PST by Aaron Train [:aaronmt]
Modified: 2012-03-15 17:21 PDT (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
11+


Attachments
patch (2.67 KB, patch)
2011-12-20 13:08 PST, :Margaret Leibovic
mark.finkle: review+
Details | Diff | Review

Description Aaron Train [:aaronmt] 2011-12-14 14:01:23 PST
bug 707886 added click to play with Fennec UI in bug 708464.  The first site I just tested was cnn.com, upper right advertisement. Tapping the UI does not activate Flash.

I/InputReader( 2715): dispatchTouch::touch event's action is 1, pending(waiting finished signal)=0
I/InputDispatcher( 2715): Delivering touch to current input target: action: 1, channel '408f2be8 org.mozilla.fennec/org.mozilla.fennec.App (server)'
I/InputDispatcher( 2715): Delivering touch to current input target: action: 1, channel 'PointerDevice-21673 (server)'
E/GeckoConsole( 4105): [JavaScript Error: "tab is null" {file: "chrome://browser/content/browser.js" line: 1928}]

Preference is set to "Tap to Play" by default

Confirmed that the feature does activate properly on another site such as the splash page at http://www.madisonavenuepub.com/

--
Samsung Galaxy SII (Android 2.3.4)
20111214113224
http://hg.mozilla.org/mozilla-central/rev/bc84b3376e14
Comment 1 Aaron Train [:aaronmt] 2011-12-14 14:22:14 PST
If it matters, I have installed the version of Flash that is bundled with the SII (not updated). Flash 10.1.105.333
Comment 2 :Margaret Leibovic 2011-12-14 14:28:21 PST
Given the line of that error in browser.js, it looks like an error in ElementTouchHelper, so the JS is probably dying before PluginHandler is getting the touch event.

Cc'ing Wes and Chris, since they've worked with this code.
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-14 14:30:31 PST
Same error as in bug 710704
Comment 4 :Margaret Leibovic 2011-12-20 13:08:28 PST
Created attachment 583261 [details] [diff] [review]
patch

I found that we were clearing the _pluginsToPlay array too often, when we should only be doing it on top-level pagehide events.

The click still doesn't work when we get the error from bug 710704, but hopefully that bug fix will fix that. The patch in there seems to fix the error, but the plugin container still isn't getting the click event sometimes (happening to me on cnn.com).
Comment 5 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-20 13:20:28 PST
Since we don't yet have explicit approval flags yet, I am giving the approval-aurora:+ here. Please land on Aurora.
Comment 6 :Margaret Leibovic 2011-12-20 13:31:39 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/4299171a937c

mozilla-aurora is closed right now, so I'll land this when it re-opens.

Also, a note for QA: This patch definitely fixes some cases where we weren't playing the plugin on click, but it doesn't fix the cases where the plugin container isn't getting the click event like it should. Hopefully bug 710704 will fix that.
Comment 7 Ed Morley [:emorley] 2011-12-21 04:31:27 PST
https://hg.mozilla.org/mozilla-central/rev/4299171a937c
Comment 8 Aaron Train [:aaronmt] 2011-12-21 08:10:51 PST
Samsung Galaxy SII (Android 2.3.4)
20111221041234
http://hg.mozilla.org/mozilla-central/rev/d6b976e83811
Comment 9 :Margaret Leibovic 2011-12-21 12:39:22 PST
Landed on aurora:

https://hg.mozilla.org/releases/mozilla-aurora/rev/7d403d73623d
Comment 10 Gabriela [:gaby2300] 2012-03-15 16:39:50 PDT
I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
Comment 11 :Margaret Leibovic 2012-03-15 16:44:38 PDT
(In reply to Gabriela from comment #10)
> I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315

What exactly are you experiencing? Did you reopen this for the same reason as reopening bug 715740? These are both pretty old bugs, and the code has changed since they've landed. I think you should file a new bug with your STR, and we can address the issue there.
Comment 12 Gabriela [:gaby2300] 2012-03-15 17:09:04 PDT
(In reply to Margaret Leibovic [:margaret] from comment #11)
> (In reply to Gabriela from comment #10)
> > I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
> 
> What exactly are you experiencing? Did you reopen this for the same reason
> as reopening bug 715740? These are both pretty old bugs, and the code has
> changed since they've landed. I think you should file a new bug with your
> STR, and we can address the issue there.

I'm seeing just the same as this bug's name: In some cases tapping to activate Flash does not activate Flash, that is, nothing happens at all, that's  why I reopened it. 

I'm sorry but if I open a new bug with a very similar name to this one, won't it be kind of discarded as a duplicate of this one? If not, I'll file it!
Comment 13 :Margaret Leibovic 2012-03-15 17:12:47 PDT
(In reply to Gabriela from comment #12)
> (In reply to Margaret Leibovic [:margaret] from comment #11)
> > (In reply to Gabriela from comment #10)
> > > I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
> > 
> > What exactly are you experiencing? Did you reopen this for the same reason
> > as reopening bug 715740? These are both pretty old bugs, and the code has
> > changed since they've landed. I think you should file a new bug with your
> > STR, and we can address the issue there.
> 
> I'm seeing just the same as this bug's name: In some cases tapping to
> activate Flash does not activate Flash, that is, nothing happens at all,
> that's  why I reopened it. 
> 
> I'm sorry but if I open a new bug with a very similar name to this one,
> won't it be kind of discarded as a duplicate of this one? If not, I'll file
> it!

I'm sorry for the confusion - it's unlikely that the same root problem that caused this original bug is causing your new bug, so that's why I think we should file a new bug. In an ideal world, this bug would have a less ambiguous summary :)

If you file a new bug and cc me, I'll be sure to look into it. In that bug description you should list which websites you're experiencing this on, so we can try to reproduce it.
Comment 14 Gabriela [:gaby2300] 2012-03-15 17:19:07 PDT
(In reply to Margaret Leibovic [:margaret] from comment #11)
> (In reply to Gabriela from comment #10)
> > I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
> 
> What exactly are you experiencing? Did you reopen this for the same reason
> as reopening bug 715740? These are both pretty old bugs, and the code has
> changed since they've landed. I think you should file a new bug with your
> STR, and we can address the issue there.

I'm seeing the same as this bug, tapping to activate Flash doesn't activate it, that's why I reopened this bug and for the same reason I reopened the other one because the same was happening with my phone.
If I file a new bug t will be very similar to this one, won't it be kind of discarded as a duplicate? If not, please tell me so I'll file it as soon as possible!
Comment 15 Gabriela [:gaby2300] 2012-03-15 17:21:30 PDT
(In reply to Margaret Leibovic [:margaret] from comment #13)
> (In reply to Gabriela from comment #12)
> > (In reply to Margaret Leibovic [:margaret] from comment #11)
> > > (In reply to Gabriela from comment #10)
> > > > I can still see this bug in Galaxy S 2, Android 2.3.4 and build 20120315
> > > 
> > > What exactly are you experiencing? Did you reopen this for the same reason
> > > as reopening bug 715740? These are both pretty old bugs, and the code has
> > > changed since they've landed. I think you should file a new bug with your
> > > STR, and we can address the issue there.
> > 
> > I'm seeing just the same as this bug's name: In some cases tapping to
> > activate Flash does not activate Flash, that is, nothing happens at all,
> > that's  why I reopened it. 
> > 
> > I'm sorry but if I open a new bug with a very similar name to this one,
> > won't it be kind of discarded as a duplicate of this one? If not, I'll file
> > it!
> 
> I'm sorry for the confusion - it's unlikely that the same root problem that
> caused this original bug is causing your new bug, so that's why I think we
> should file a new bug. In an ideal world, this bug would have a less
> ambiguous summary :)
> 
> If you file a new bug and cc me, I'll be sure to look into it. In that bug
> description you should list which websites you're experiencing this on, so
> we can try to reproduce it.

Right, I'll file a new one, I'll add the websites where I have the issue and I'll cc you. Thanks!

Note You need to log in before you can comment on or make changes to this bug.