Debug->Verification options present on builds with --disable-tests

VERIFIED DUPLICATE of bug 59655

Status

SeaMonkey
Build Config
VERIFIED DUPLICATE of bug 59655
17 years ago
12 years ago

People

(Reporter: earthsound, Assigned: cls)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; 0.8) Gecko/20010215
BuildID:    2001021508

When selecting one of the aforementioned debug>verification options, they do not
work. It appears as though they link to either a missing file (in
bin\res\samples\test) or they link to a file generated dynamically by Mozilla
that is _very_ basic (i.e. <html><body></body></html>)

Reproducible: Always
Steps to Reproduce:
Go to menu item "Debug>Verification":
1. click "Tables"
2. Mozilla takes me to resource:///res/samples/test6.html, which doesn't exist 
3. view the page source
4. it is very simple: <html><body></body></html>
5. it should be a test of table rendering

Actual Results:  got a blank (non-existent) page

Expected Results:  Taken me to a page that tests Mozilla's table rendering
capabilities.

Nearly the same results as above for the other menu items I mentioned in
summary, except for the following discrepancies:

After clicking "JavaScript", I am sent to abcnews.go.com
After clicking "JPEG Images", I am sent to resource:///res/samples/test2.html
(non-existent)
After clicking "Transparency", I am sent to resource:///res/samples/test13.html
(non-existent)
After clicking "Animation", I am sent to resource:///res/samples/test2.html
(again, non-existent)
*** Bug 71111 has been marked as a duplicate of this bug. ***
Assignee: asa → waterson
Status: UNCONFIRMED → NEW
Component: Browser-General → XP Miscellany
Ever confirmed: true
OS: Windows 98 → All
QA Contact: doronr → brendan
Hardware: PC → All
Summary: menu item debug>verification>... problems - tables, javascript, JPEG Images, Transparency, & Animation do not work → Debug->Verification options present on builds with --disable-tests
at a guess, the nightly builds are built with the --disable-tests option.  In my
CVS build that menu works fine, with my nightly it does not.

I would say that entire menuitem should not be there if one builds with
--disable-tests....

Comment 3

17 years ago
-> build/config. maybe packaging.
Assignee: waterson → cls
Component: XP Miscellany → Build Config
QA Contact: brendan → granrose
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 59655 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
vrfy dupe of bug 59655 Need a way to remove QA and debug menus via a build 
options
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.