download of apk automatically executes it

RESOLVED INVALID

Status

RESOLVED INVALID
7 years ago
6 years ago

People

(Reporter: dietrich, Unassigned)

Tracking

Trunk
x86
macOS

Details

(Reporter)

Description

7 years ago
is this intended behavior? the xul fennec didn't do this, and neither does the stock browser last i checked.

STR:

1. open native fennec
2. go to http://nightly.mozilla.org/
3. click on android

Expected:

file downloads, shows up in downloads folder, notification of download completed shows up in android status bar, etc.

Actual:

file downloads, install process begins!
this is intended behavior for files that have handlers. XUL Fennec should have done the same thing. I actually thought that stock did the same thing too.

The same thing happens if you tap on a link to a PDF file. We download and open the PDF in a reader, if you have one installed.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
This is causing some pretty confusing behavior on http://badoo.com , it seems.
There, an .apk file is downloaded and automatically shown in some kind of web viewer. It makes it look like Fennec is showing that page, but it isn't really.
I suspect that site is serving the content as application/vnd.wap.xhtml+xml , which Mozilla doesn't support, see bug 209637.
This is related to bug 690252, I guess.
Depends on: 690252
You need to log in before you can comment on or make changes to this bug.