thumbnails on about:home are really poor quality

VERIFIED FIXED in Firefox 11

Status

()

defect
P1
normal
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: dietrich, Assigned: blassey)

Tracking

unspecified
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 verified, fennec11+)

Details

Attachments

(2 attachments)

they are super pixelated and grody looking.
going to zimbra shows this off quite well.
Priority: -- → P3
I think we can just bump up the size of the saved thumbnails a little bit. We are saving them as 96x96 pixel. I see that the ICS browser code uses 240x160
Priority: P3 → P1
OS: Mac OS X → Android
Hardware: x86 → ARM
tracking-fennec: --- → 11+
Posted patch patchSplinter Review
Assignee: nobody → blassey.bugs
Attachment #587614 - Flags: review?(mark.finkle)
Posted image screen shot
Comment on attachment 587614 [details] [diff] [review]
patch

r+, but lets use 240x160 for the dimensions
Attachment #587614 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/ba96b6a034c2
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
(In reply to Matt Brubeck (:mbrubeck) from comment #6)
> https://hg.mozilla.org/mozilla-central/rev/ba96b6a034c2
That still specifies 120x80 !?
(In reply to Steffen Wilberg from comment #7)
> (In reply to Matt Brubeck (:mbrubeck) from comment #6)
> > https://hg.mozilla.org/mozilla-central/rev/ba96b6a034c2
> That still specifies 120x80 !?

That is the mdpi values. The patch is scaling those based on the DPI, so on ICS where the DPI scale is 2, we are at 240x160.
Comment on attachment 587614 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
unreadable, unrecognizable  thumbnails
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
using more memory in the DB to store the thumbnails
Attachment #587614 - Flags: approval-mozilla-aurora?
Attachment #587614 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified fixed on Nightly 12.0a1 (2012-01-31)
                  Aurora  11.0a2 (2012-01-31)
Device:Samsung Galaxy S2 (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.