Last Comment Bug 711203 - XPConnect wstring test doesn't get called
: XPConnect wstring test doesn't get called
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Bobby Holley (:bholley) (busy with Stylo)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-15 11:49 PST by Bobby Holley (:bholley) (busy with Stylo)
Modified: 2011-12-16 05:44 PST (History)
2 users (show)
Ms2ger: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
enable XPConnect wstring test. v1 (1.24 KB, patch)
2011-12-15 12:18 PST, Bobby Holley (:bholley) (busy with Stylo)
khuey: review+
Details | Diff | Splinter Review

Description Bobby Holley (:bholley) (busy with Stylo) 2011-12-15 11:49:47 PST
I noticed this on bug 708499. It wouldn't have made us catch that issue (since we don't check for those kind of leaks on tinderbox), but it would have been nice to facilitate manual testing.

I've fixed this on both branches. This bug is to fix it on central. Patch coming right up.
Comment 1 Bobby Holley (:bholley) (busy with Stylo) 2011-12-15 12:18:54 PST
Created attachment 582065 [details] [diff] [review]
enable XPConnect wstring test. v1

Attached a patch. Flagging khuey for rubberstamp.
Comment 2 Bobby Holley (:bholley) (busy with Stylo) 2011-12-15 13:29:40 PST
Pushed to mozilla-inbound: http://hg.mozilla.org/integration/mozilla-inbound/rev/c17b09e6654f
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2011-12-16 05:44:56 PST
https://hg.mozilla.org/mozilla-central/rev/c17b09e6654f

Note You need to log in before you can comment on or make changes to this bug.