Crash on closing composer after switching themes

VERIFIED DUPLICATE of bug 43350

Status

Core Graveyard
Skinability
P1
critical
VERIFIED DUPLICATE of bug 43350
17 years ago
10 years ago

People

(Reporter: Koike Kazuhiko, Assigned: Simon Fraser)

Tracking

({crash})

Trunk
mozilla0.9
x86
All
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Crash on closing composer after switching themes.

(1) Open composer window and navigator window.
(2) switch theme.
(3) Try to close composer window by [File]-[Close]. Nothing happens.
(4) Close composer window by close button on titlebar. Crash happens.

Build: 2001030605.
->skinability?
Component: XP Apps: GUI Features → Skinability
Keywords: crash
QA Contact: sairuh → blakeross
(Reporter)

Comment 2

17 years ago
Reproduced with 2001030810/Linux.
OS: Windows 2000 → All
(Reporter)

Comment 3

17 years ago
Crash happens if you changed theme from modern to classic.

Comment 4

17 years ago
*** Bug 71839 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

17 years ago
*** Bug 72076 has been marked as a duplicate of this bug. ***

Comment 6

17 years ago
Marking nsbeta1+, p1, mozilla0.9, reassigning to mcafee.

Chris, can you take a look into this one, thanks.
Assignee: ben → mcafee
Keywords: nsbeta1+
Priority: -- → P1
Target Milestone: --- → mozilla0.9
(Reporter)

Comment 7

17 years ago
2001033105/Linux doesn't crash.

Comment 8

17 years ago
I get (3) to reproduce, e.g. composer window doesn't crash,
but I don't crash (linux).

Comment 9

17 years ago
I did try composer a few times in other modes and got
File|Close to do nothing in one case, error listed below.
Over to beppe for a look from composer team.

************************************************************
* Call to xpconnect wrapped JSObject produced this error:  *
[Exception... "Component returned failure code: 0x80004002 (NS_NOINTERFACE)
[nsIEditorShell.editorDocument]"  nsresult: "0x80004002 (NS_NOINTERFACE)" 
location: "JS frame :: chrome://editor/content/editor.js :: SetEditMode :: line
1042"  data: no]
Assignee: mcafee → beppe

Comment 10

17 years ago
assigning to simon -- isn't there a bug already open for this?
Assignee: beppe → sfraser

Comment 11

17 years ago
could this be covered by bug 43350?
(Assignee)

Comment 12

17 years ago
Don't we put up the dialog telling you to close composer windows before switching 
themes? How do you get into a state where you can switch themes with open 
composer windows?

Comment 13

17 years ago
*** Bug 75476 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
If you open the preferences, you do not get any warning about saving the
composer file.
(Assignee)

Comment 15

17 years ago
We no longer show the theme switching warning dialog, which told you to close 
composer windows. I'm duping this to bug 43350


*** This bug has been marked as a duplicate of 43350 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: blakeross → pmac

Comment 16

17 years ago
Lots of verifications.

If I had to test stuff, it was on Win2K, build id 2001052404.
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.