Investigate if bloom filters could improve the performance of nsEventListenerManager::HandleEventInternal

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
7 years ago
5 years ago

People

(Reporter: smaug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
If ELM could store a bit array and registered events types would be stored in it,
testing whether ELM has a listener for certain type might become faster, at least
in case there are lots of listeners.
Using some tricks the bit array could be perhaps spread to the left-over bits of
ListenerStructs.

Need to profile.
(Reporter)

Comment 1

7 years ago
Created attachment 582400 [details] [diff] [review]
perf test impl

The answer seems to be that the filter doesn't improve anything but some
very artificial tests.
Posted to tryserver anyway
https://tbpl.mozilla.org/?tree=Try&rev=6971afaf8ba3
(Reporter)

Updated

5 years ago
Assignee: bugs → nobody
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.