How to change the default preferences in Quick Search Bar to 'Search Subject or Sender' instead of the default 'Search Subject or Address'

RESOLVED DUPLICATE of bug 528229

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 528229
6 years ago
6 years ago

People

(Reporter: shubhyant.chaturvedi, Unassigned)

Tracking

SeaMonkey 2.5 Branch
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:8.0.1) Gecko/20111121 Firefox/8.0.1 SeaMonkey/2.5
Build ID: 20111121023255

Steps to reproduce:

In Seamonkey 2.5 Mail browser, the quick search bar has the default of 'Search Subject or Address'. I would like to change it to 'Search Subject or Sender' (similar to how it was in some of the earlier versions of Seamonkey). I would like to know how do I make that change.

Thanks,
-Shubhyant
IIUC the quick & dirty hack would be to find the text in question in the en-US language pack, and build a "doctored" private-use langpack for a bogus locale (en-SC maybe?) that would include the changed string. This would be accompanied by resolving this bug INVALID "not a Mozilla bug" — the fix would be elsewhere.

Making the change permanently in official SeaMonkey builds would be similar — minus the change of locale, but plus a change in every _other_ locale, which would mean a lot of work for the l10n team and also quite some red tape (write a patch, have it reviewed by some UI reviewer, then superreviewed by Mnyromyr, and finally pushed to trunk only, since strings are frozen at the central-to-aurora merge). I suspect that it would get WONTFIXed at some point, but I can't be sure.
Component: General → MailNews: Message Display
QA Contact: general → message-display

Updated

6 years ago
Duplicate of this bug: 711318

Comment 3

6 years ago
If I understand the original question correctly, this is not about changing the *label* but the *function* of the quick search. At some time (I don't recall the bug number right now) it was changed from "Sender" to "Address", thus also searching for "To" and "Cc" header matches. In contrast to Thunderbird, this is hard-wired in SeaMonkey, unless that can be changed by a localized string as suggested in comment #1.

Comment 4

6 years ago
That's bug 518846 for the change of function and bug 399722 to make search criteria configurable like in Thunderbird. There is also bug 528229 asking for a preference setting to pick "Sender" or "Address" (of which this report may be a duplicate).

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 528229
You need to log in before you can comment on or make changes to this bug.