Last Comment Bug 711359 - [BC]Table border incorrectly rendered after 'display:none'ing some table rows
: [BC]Table border incorrectly rendered after 'display:none'ing some table rows
Status: VERIFIED FIXED
[qa!]
: regression, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: Bernd
:
Mentors:
Depends on:
Blocks: 460637 712849
  Show dependency treegraph
 
Reported: 2011-12-16 02:29 PST by Daniel Glazman (:glazou)
Modified: 2012-02-10 07:04 PST (History)
11 users (show)
bernd_mozilla: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
verified


Attachments
screenshot of the bug, OS X 10.6.5, Nightly 11.0a1 2011-12-15 (141.18 KB, image/png)
2011-12-16 02:29 PST, Daniel Glazman (:glazou)
no flags Details
reduced testcase (1.44 KB, text/html)
2011-12-18 10:19 PST, Bernd
no flags Details
patch (2.97 KB, patch)
2011-12-19 22:00 PST, Bernd
no flags Details | Diff | Splinter Review
revised patch (3.46 KB, patch)
2011-12-24 02:33 PST, Bernd
no flags Details | Diff | Splinter Review
revised patch (5.01 KB, patch)
2011-12-24 03:42 PST, Bernd
no flags Details | Diff | Splinter Review
revised patch (5.02 KB, patch)
2011-12-26 00:43 PST, Bernd
mats: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Daniel Glazman (:glazou) 2011-12-16 02:29:27 PST
Created attachment 582218 [details]
screenshot of the bug, OS X 10.6.5, Nightly 11.0a1 2011-12-15

This is a regression visible in Nigthlies (I am currently using 11.0a1 2011-12-15) and not in FF8.

1. Open http://bluegriffon.org/pages/Community#localizeBlueGriffon

2. select locales a few times using the dropdown menu inside the page

3. after a few locale selections, the table becomes incompletely rendered,
   see attached screenshot

The page gives a "display: none" to all table rows that are not of the
selected locale. Nothing else. Tested on Mac OS X 10.6.5.
Comment 1 Mats Palmgren (vacation) 2011-12-17 21:14:59 PST
Regression range (Linux64 builds):  2011-11-28-03-10-52 -- 2011-11-29-03-10-19
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=854aabf544d4&tochange=bc48009a6bbb
I suspect bug 460637.
Comment 2 Mats Palmgren (vacation) 2011-12-17 21:54:48 PST
Daniel, FYI, changing the value using keyboard commands doesn't work since you only
have onclick on the <select>
Comment 3 Daniel Glazman (:glazou) 2011-12-18 00:09:53 PST
(In reply to Mats Palmgren [:mats] from comment #2)
> Daniel, FYI, changing the value using keyboard commands doesn't work since
> you only
> have onclick on the <select>

d'oh, yes, a mistake; but that has no link with the regression describes here.
Comment 4 Bernd 2011-12-18 01:29:41 PST
A reduced test case that demonstrates this would be fine
Comment 5 Bernd 2011-12-18 10:19:02 PST
Created attachment 582681 [details]
reduced testcase
Comment 6 Bernd 2011-12-19 22:00:23 PST
Created attachment 583071 [details] [diff] [review]
patch
Comment 7 Bernd 2011-12-19 22:25:59 PST
the patch fixes only the reduced testcase but the page still does show problems.
Comment 8 Bernd 2011-12-24 02:33:23 PST
Created attachment 584170 [details] [diff] [review]
revised patch

this fixes the url and bug 712849
Comment 11 Mats Palmgren (vacation) 2011-12-26 04:48:43 PST
Comment on attachment 584314 [details] [diff] [review]
revised patch

>+  // mark all following rows  damaged ...

s/mark/Mark/ and delete the extra space before "damaged"

>   SetDamageArea(0, aRgFirstRowIndex + startRowIndex, aMap.GetColCount(),
>-                1 + endRowIndex - startRowIndex, aDamageArea);
>+                aMap.GetRowCount() - aRgFirstRowIndex - startRowIndex,
>+                aDamageArea);

I think this would be clearer with a temp variable, like so:

  PRInt32 firstDamagedRow = aRgFirstRowIndex + startRowIndex;
  SetDamageArea(0, firstDamagedRow, aMap.GetColCount(),
                aMap.GetRowCount() - firstDamagedRow,
                aDamageArea);
Comment 13 Matt Brubeck (:mbrubeck) 2011-12-27 11:22:14 PST
https://hg.mozilla.org/mozilla-central/rev/ab7997839419
Comment 14 Bernd 2011-12-29 00:10:27 PST
Comment on attachment 584314 [details] [diff] [review]
revised patch

this fixes a rendering regression that got uplifted to aurora
Comment 15 christian 2011-12-29 09:56:50 PST
Comment on attachment 584314 [details] [diff] [review]
revised patch

[triage comment]
Approved for aurora. This is a rendering regression we do not want to ship.
Comment 16 Bernd 2011-12-31 09:30:51 PST
fixed on aurora
Comment 18 Maniac Vlad Florin (:vladmaniac) 2012-02-10 05:56:05 PST
Verified 
Build identifier: Mozilla/5.0 (X11; Linux i686; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 19 Maniac Vlad Florin (:vladmaniac) 2012-02-10 06:04:41 PST
Verified 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 20 Alex Lakatos[:AlexLakatos] 2012-02-10 07:04:01 PST
Verified Build identifier: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0

Note You need to log in before you can comment on or make changes to this bug.