duplicate bookmarks after unexpected system shutdown

RESOLVED INVALID

Status

Cloud Services
Firefox Sync: Backend
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: jimm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 582260 [details]
bookmarks

After a power outage shut down my system unexpectedly last night - basically, one folder on my favorites bar (my main mz folder) had it's contents duplicated three times. AFAICT, this was the only folder that experienced the duplication. Also, note, not all contents were duplicated, some links are missing from each set.

If I can help debug this in some way, please let me know.
(Reporter)

Updated

6 years ago
Component: General → Firefox Sync: UI
QA Contact: general → sync-ui
Jim: which version of Firefox, and can you provide Sync logs? See here:

https://philikon.wordpress.com/2011/06/13/how-to-file-a-good-sync-bug/

for instructions. A log (error or success) from the time of the sync, if one existed -- which I doubt -- would be helpful.

If that was a stable folder -- not added or modified recently -- then this is more likely to be a Places bug than a Sync bug. (Databases don't like being killed mid-write!)

If the entire folder is unmodified on both server and client, then it shouldn't get touched by Sync.
Component: Firefox Sync: UI → Firefox Sync: Backend
QA Contact: sync-ui → sync-backend
(Reporter)

Comment 2

6 years ago
Ah, didn't know about about:sync-log. My last log was on the 12th, so yes, it looks like this was caused by something other than sync.

I suppose if it was a trashed db due to the power outage, there's not much we can do about it. So I'm going to resolve this invalid.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.