Sync progress bar is displayed after browser restart

RESOLVED WORKSFORME

Status

Cloud Services
Firefox Sync: UI
RESOLVED WORKSFORME
6 years ago
5 years ago

People

(Reporter: mihaelav, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Mozilla/5.0 (Windows NT 6.1; rv:10.0a2) Gecko/20111215 Firefox/10.0a2

If browser is restarted during initial sync, progress bar is displayed at restart, but it is greyed out and not functional

Steps to reproduce:
1. Set up sync
2. While initial sync is in progres close the browser
3. Restart the browser and check about:sync-progress page

Actual result:
Sync progress bar is displayed.

Expected result:
Sync progress bar should not be displayed at restart
I seem to recall that we did this deliberately, so that you get feedback even if you didn't allow the initial sync to complete, but I might be misremembering.

Certainly if it does appear, it should function. Did you wait until a sync occurred, or force one, and see if the page springs to life?

Ally, care to comment?
Hardware: x86 → All
Yes, we deliberately kept the about:sync-progress page as an open tab, but the progress bar shouldn't be visible. Mihaela, can you please attach a screenshot of what you're seeing?
Note that it may be possible that, if you interrupt the initial sync, Sync may repeat the initial sync after the browser restart. In that case I think it's perfectly fine that the progress bar is still displayed. After all, the initial sync was never completed fully.
(Reporter)

Comment 4

6 years ago
Sync progress bar is displayed at browser restart and it shows the progress on
Mozilla/5.0 (Windows NT 6.1; rv:10.0.1) Gecko/20100101 Firefox/10.0.1

I could not reproduce on:
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0 beta2
Mozilla/5.0 (Windows NT 6.1; rv:12.0a2) Gecko/20120212 Firefox/12.0a2
Mozilla/5.0 (Windows NT 6.1; rv:13.0a1) Gecko/20120212 Firefox/13.0a1
 -> Sync progress bar is not displayed at browser restart
Good enough.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.