Need thread stack traces on native crashes in logcat

RESOLVED WONTFIX

Status

()

Firefox for Android
General
P4
normal
RESOLVED WONTFIX
6 years ago
a year ago

People

(Reporter: kats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Debugging crashes in Gecko is hard because often they are not consistently reproducible, particularly on different devices. Bug 711426 is an example of such a bug. It would be really nice to get Gecko stack dumps in logcat on a crash, so that the issues can be quickly diagnosed.
+1 to this, or simpler GDB tutorial/instructions for QA
Priority: -- → P4
This is kind of hard on release builds, unless you're willing to ship with frame pointers enabled. Even then I'm not sure if we have usable code in mozilla-central that can do this at the moment.
I noticed that android sometimes prints something that looks like stack scanning to logcat on a crash. I don't know what conditions that is.
How about keeping the crashed process "running" while the crash reporter is being shown, which would give a chance to attach a debugger?
(In reply to Mike Hommey [:glandium] from comment #4)
> How about keeping the crashed process "running" while the crash reporter is
> being shown, which would give a chance to attach a debugger?

I've been wanting to do that in bug 721843. I ran into some 'mysterious' issues that jimb explained to me. We could continue on that approach. But we wouldn't be able to catch OOM crash unfortunately which would be particularly useful. I know bjacob runs into them a lot trying to debug desktop WebGL demo running on mobile causing OOM.
There's really nothing we can do to catch anything in OOM cases.
I'm going to close this bug since it's unlikely that we're going to focus much direct attention on it. It seems like our crash info has been steadily improving our time (and our crash rate has correspondingly dropped) so there's no need for any focused effort on this beyond projects that are already under way.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.