Last Comment Bug 711611 - NSPR's obsolete int32, int64, etc. types get defined without an opt-out #define
: NSPR's obsolete int32, int64, etc. types get defined without an opt-out #define
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla11
Assigned To: Jeff Walden [:Waldo] (remove +bmo to email)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-16 14:07 PST by Jeff Walden [:Waldo] (remove +bmo to email)
Modified: 2011-12-17 09:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Potential patch, being tryservered now (583 bytes, patch)
2011-12-16 14:07 PST, Jeff Walden [:Waldo] (remove +bmo to email)
bhackett1024: review+
Details | Diff | Splinter Review

Description Jeff Walden [:Waldo] (remove +bmo to email) 2011-12-16 14:07:11 PST
Created attachment 582387 [details] [diff] [review]
Potential patch, being tryservered now

"These definitions are scheduled to be eliminated at the earliest possible time."

Yeah.  Right.  By the way, are you in the market for a bridge?

This leaks in through jslock.h, which in threadsafe builds includes various NSPR headers.  Le sigh.  Before this patch, an int32 i; in jsinterp.cpp would build.  After, it fails to build.

I'll wait for try results on this, since it's possible this could have hidden other failures in Gecko, but the approach is reviewable without further ado.
Comment 1 Jeff Walden [:Waldo] (remove +bmo to email) 2011-12-16 17:03:37 PST
Built on try, pushed:

https://hg.mozilla.org/integration/mozilla-inbound/rev/020e3a98f85e
Comment 2 Matt Brubeck (:mbrubeck) 2011-12-17 09:31:25 PST
https://hg.mozilla.org/mozilla-central/rev/020e3a98f85e

Note You need to log in before you can comment on or make changes to this bug.