Last Comment Bug 711642 - ResizeOffscreenFBO should deguarantee that it does anything but resize the FBO
: ResizeOffscreenFBO should deguarantee that it does anything but resize the FBO
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla13
Assigned To: Jeff Gilbert [:jgilbert]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on: 701269
Blocks: 722195
  Show dependency treegraph
 
Reported: 2011-12-16 15:24 PST by Jeff Gilbert [:jgilbert]
Modified: 2012-02-02 07:16 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Deguarantee ResizeOffscreenFBO sets the viewport on first run (1.68 KB, patch)
2011-12-16 16:03 PST, Jeff Gilbert [:jgilbert]
jacob.benoit.1: review+
Details | Diff | Splinter Review

Description Jeff Gilbert [:jgilbert] 2011-12-16 15:24:09 PST
ResizeOffscreenFBO does things other than resizing FBOs. It shouldn't, because other code begins to expect it to then do things that are not guaranteed.

One thing I see is that we are setting the viewport to the correct size the first time we run. Unfortunately, we're bad at determining when is the first time vs. subsequent times. This should be done in the code which initializes the context, not in resize code.

An early-out added in bug 615976 makes it very important we know what our guarantees are, and aren't.
Comment 1 Jeff Gilbert [:jgilbert] 2011-12-16 16:03:28 PST
Created attachment 582426 [details] [diff] [review]
Deguarantee ResizeOffscreenFBO sets the viewport on first run

We already set the viewport correctly for WebGL initialization.
Comment 2 Jeff Gilbert [:jgilbert] 2012-01-04 02:54:21 PST
I will run this by try, then land it.
Comment 3 Jeff Gilbert [:jgilbert] 2012-02-01 12:42:46 PST
Try run at https://tbpl.mozilla.org/?tree=Try&rev=e8b8a919fe13 is clean.
Comment 5 Ed Morley [:emorley] 2012-02-02 07:16:52 PST
https://hg.mozilla.org/mozilla-central/rev/c96f7298db5b

Note You need to log in before you can comment on or make changes to this bug.