Closed Bug 711742 Opened 8 years ago Closed 6 years ago

HTML5 video's "Save Video As" saves an empty .webm file if you have not actually played the video

Categories

(Core :: Audio/Video, defect)

defect
Not set

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox20 --- unaffected
firefox23 --- unaffected
firefox26 --- affected
firefox27 --- affected
firefox28 --- unaffected
firefox29 --- unaffected
firefox-esr24 --- affected

People

(Reporter: cpeterson, Assigned: d3f3kt)

References

()

Details

(Whiteboard: [10b1])

STR:
1. Load http://blog.gerv.net/2011/12/distributed-workin/
2. Right-click on HTML5 video
3. Select "Save Video As..."

AR:
The .webm file that is saved is only 25 KB and contains no video content.

ER:
If you play the video (and wait for the progress bar to show that the entire video has been loaded) and then save the video, the .webm file is 38 MB and contains the entire video.

* I can repro this bug on Firefox 8, Aurora 10, and Nightly 11.
I can confirm that this issue is reproducible also on Windows XP, Windows 7 and Ubuntu 11.10 using Firefox 10 beta 1.

Mozilla/5.0 (Windows NT 5.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0

I experienced this issue when playing an ogv video. The video is not entirely downloaded when saving it for the first time. When saving the video the second time it's entirely downloaded. 

Steps to reproduce:
1. Load http://videos.mozilla.org/firefox/3.6/getpersonas.ogv
2. Right click on the video and from the context menu select Save Video As

Expected results:
The video is saved entirely.

Actual results:
At the first download the video is partially saved. Then, if I repeat the saving process once again (Save Video AS option) then the video is properly saved. 
On the other hand, if I refresh the video window and then I try to save it again, the first behavior is still encountered (video is partialy saved).
OS: Mac OS X → All
Hardware: x86 → All
Whiteboard: [10b1]
Simona, can you see if this has a regression window?
I believe this bug was injected between Firefox 7 and 8. Here are my test results:

FF 5.0.1 = PASS
FF 6.0.2 = PASS
FF 7.0.1 = PASS
FF 8.0b1 = FAIL <<<
FF 8.0.1 = FAIL
FF 9.0.1 = FAIL
FF 10.0b3 = FAIL

I also discovered that the buggy builds will correctly download the complete video if you right-click and "Save Video As" *twice*.
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #2)
> Simona, can you see if this has a regression window?

Last good nightly: 2011-07-16
First bad nightly: 2011-07-17

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=48dcb60519ac&tochange=da362a07a5ee
Sounds like bug 564387 is the culprit here.
Blocks: 564387
For one thing, that bug's patch ensures we no longer bypass the cache when saving a video.
Reproducible also on Firefox 10.0.3 ESR build 2.

Mozilla/5.0 (Windows NT 6.0; rv:10.0.3) Gecko/20100101 Firefox/10.0.3
Reproducible on Firefox 14 beta 6:
Mozilla/5.0 (Windows NT 5.1; rv:14.0) Gecko/20100101 Firefox/14.0
Assignee: nobody → david
(In reply to Chris Peterson (:cpeterson) from comment #0)
> STR:
> 1. Load http://blog.gerv.net/2011/12/distributed-workin/
> 2. Right-click on HTML5 video
> 3. Select "Save Video As..."

I can't reproduce w/ this URL, FWIW.

(In reply to Simona B [QA] from comment #1)
> Steps to reproduce:
> 1. Load http://videos.mozilla.org/firefox/3.6/getpersonas.ogv
> 2. Right click on the video and from the context menu select Save Video As

... or with this URL.  I'm using a fairly-recent nightly:
Mozilla/5.0 (X11; Linux x86_64; rv:22.0) Gecko/20130314 Firefox/22.0

Can anyone reproduce in nightly? or has this become WORKSFORME?
Just kidding -- I didn't get the full file, at least in the case of the getpersonas video. I got a ~1 meg file, which I thought was valid (I could play it w/ mplayer), but if I try to play all the way through it, I can see that it's truncated.

So I can reproduce after all, sorry for the confusion.
Interesting. I got an 8.5M getpersonas file, even when I was careful not to load the video first. Maybe it depends on whether it's in the media cache?
Firefox 19.0.2 on Ubuntu 12.04.2:
 * getpersonas.ogv downloads as 8.4MB
 * HomaBahrami_Mozilla_as_distributed_org.webm downloads as 38.1MB

At least for me this remains unreproducible.
My original STR from comment #0 works for me in Firefox 20 and 23. :D
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Try this file: http://videos.mozilla.org/firefox/3.6/getpersonas.ogv
You cant download the whole file with the first try. So the bug is still alive.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Using the ogv video in comment 14, I can reproduce this bug in Firefox 24, 26, and Beta 27. I cannot reproduce the bug in Aurora 28 or Nightly 29. If this bug has been fixed in Aurora 28, I highly doubt release management will approve a fix to be uplifted to Beta 28 just two weeks before it is released. :)
Status: REOPENED → RESOLVED
Closed: 7 years ago6 years ago
Resolution: --- → WORKSFORME
It's possible this was inadvertently fixed when Firefox 28 was in Nightly. Could you use the mozregression tool to track down a fix range?
You need to log in before you can comment on or make changes to this bug.