Closed Bug 711751 Opened 8 years ago Closed 7 years ago

Startup crash on Gingerbread: AndroidGraphicBuffer: GL error @ . | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev

Categories

(Firefox for Android :: Toolbar, defect, P5, critical)

14 Branch
ARM
Android
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: steffen.wilberg, Unassigned)

References

Details

(Keywords: crash, regression, Whiteboard: [native-crash][startupcrash])

Crash Data

Attachments

(1 file)

Attached file logcat
My self-built Fennec Native crashes on startup (Samsung Galaxy S running Cyanogenmod 7.1, Android 2.3.7). Didn't happen 24 hours ago.

From logcat before the crash (full logcat from startup to crash is attached):
I/Gecko   ( 1176): nsWindow::GetLayerManager
I/Gecko   ( 1176):  -- creating basic, not accelerated
I/AndroidGraphicBuffer( 1176): GL error [glEGLImageTargetTexture2DOES]:                                      501
W/GraphicBufferAllocator( 1176): free(...) failed -22 (Invalid argument)
I/DEBUG   ( 1168): debuggerd committing suicide to free the zombie!
I/DEBUG   ( 1205): debuggerd: Oct  9 2011 20:22:36
I/ActivityManager(  206): Process org.mozilla.fennec_sw (pid 1176) has died.
I/WindowManager(  206): WIN DEATH: Window{40885d58 SurfaceView paused=false}
E/InputDispatcher(  206): channel '40856ad8 org.mozilla.fennec_sw/org.mozilla.fennec_sw.App (server)' ~ Consumer closed input channel or an error occurred.  events=0x8
E/InputDispatcher(  206): channel '40856ad8 org.mozilla.fennec_sw/org.mozilla.fennec_sw.App (server)' ~ Channel is unrecoverably broken and will be disposed!
I/WindowManager(  206): WIN DEATH: Window{40856ad8 org.mozilla.fennec_sw/org.mozilla.fennec_sw.App paused=false}
W/InputManagerService(  206): Got RemoteException sending setActive(false) notification to pid 1176 uid 10092
D/Zygote  (  113): Process 1176 exited cleanly (11)
Blocks: 670930
Summary: Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7) → Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error
Keywords: regression
Whiteboard: [native-crash]
Do we get a crash report submitted through our crash reporter system? If so, we should add the signature here.
I installed the tinderbox-build, sent the crash report, and installed the nightly (not yet affected) to access about:crashes...
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ dlfree | free | _ZdlPv ]
Summary: Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error → Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error [@ __libc_android_abort | dlfree | free | _ZdlPv ]
Depends on: 706006
Priority: -- → P5
We also fail to realloc the buffer:

W/GraphicBufferAllocator( 1176): alloc(1024, 1024, 4, 47c13220, ...) failed -22 (Invalid argument)

We should consider treating a realloc problem as fatal for gralloc
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ dlfree | free | _ZdlPv ] → [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev]
Summary: Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error [@ __libc_android_abort | dlfree | free | _ZdlPv ] → Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error @ . | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev
Whiteboard: [native-crash] → [native-crash], startupcrash
Still occurring:

https://crash-stats.mozilla.com/query/query?product=FennecAndroid&version=ALL%3AALL&range_value=30&range_unit=days&date=02%2F09%2F2012+16%3A36%3A50&query_search=signature&query_type=contains&query=GraphicBuffer&reason=&build_id=&process_type=any&hang_type=any&do_query=1
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] → [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ @0x0 | _ZN7android2spINS_13…
Is it a dupe of bug 725081?
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ @0x0 | _ZN7android2spINS_13… → [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev]
It's not specific to a device.

Oddly, _ZdlPv is supposed to be in the ignore skiplist (see bug 706006).
Summary: Startup crash on Samsung Galaxy S / CyanogenMod 7.1 (Android 2.3.7): AndroidGraphicBuffer: GL error @ . | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev → Startup crash on Gingerbread: AndroidGraphicBuffer: GL error @ . | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev
Whiteboard: [native-crash], startupcrash → [native-crash][startupcrash]
With combined signatures, it's now #1 top crasher in 14.0.1 and #17 in 15.0b4.
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv ] [@ __libc_android_abort | dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] [@ dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv | _ZN7android13GraphicBufferD0Ev] → [@ __libc_android_abort | dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv] [@ _ZdlPv]
Component: General → Graphics, Panning and Zooming
Keywords: topcrash
Version: unspecified → Firefox 14
Crash Signature: [@ __libc_android_abort | dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv] [@ _ZdlPv] → [@ __libc_android_abort | dlfree | free | _ZdlPv] [@ dlfree | free | _ZdlPv]
There are 41 crashes in 16.0.1.
Keywords: topcrash
Severity: blocker → critical
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.