Inspector should have a gradient tooltip for css values as appropriate

RESOLVED DUPLICATE of bug 706102

Status

DevTools
Inspector
RESOLVED DUPLICATE of bug 706102
7 years ago
8 days ago

People

(Reporter: miker, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [computedview][ruleview])

Attachments

(1 attachment)

Web developer style tools should have a gradient tooltip for css values as appropriate.
Please see meta bug 711947 for more info
Filter on PEGASUS
Whiteboard: [computedview][ruleview]
Created attachment 712185 [details]
Gradient Tooltip

It should look something like this (screenshot courtesy of Lea Verou).

The code she uses for her previews is at https://github.com/LeaVerou/dabblet/blob/master/code/previewers.js

She says that if we use her code (with changes) we should credit her in the file header.
Gradient catching regex:
/\b(repeating-)?(linear|radial)-gradient\(((rgb|hsl)a?\(.+?\)|[^\)])+\)/gi
Summary: Web developer style tools should have a gradient tooltip for css values as appropriate → Inspector should have a gradient tooltip for css values as appropriate
Component: Developer Tools: Style Editor → Developer Tools: Inspector
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 706102

Updated

8 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.