progress elements incorectly refreshes on value change on Windows

RESOLVED DUPLICATE of bug 661364

Status

()

Core
Widget: Win32
RESOLVED DUPLICATE of bug 661364
6 years ago
5 years ago

People

(Reporter: gadjo, Unassigned)

Tracking

(Blocks: 1 bug, {html5, polish})

Trunk
html5, polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [parity-chrome])

Attachments

(1 attachment)

155 bytes, text/html
Details
(Reporter)

Description

6 years ago
Created attachment 582808 [details]
Test case

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

On frequent change of the progress element value it is redrawn and the throbber (? not sure if it's good name for it - I mean the slight pattern going from the left to right side in Win7) starts going from the beggining.
The best will be to look at the test case and compare it in Fx8 and Ch16
(Reporter)

Updated

6 years ago
Blocks: 344614
Keywords: html5, polish
Whiteboard: [parity-chrome]
(Reporter)

Updated

6 years ago
Attachment #582808 - Attachment mime type: text/plain → text/html
I can't test this on Windows right now. It might be interesting to try on Windows 7 and Windows XP. Also, what about MacOS?

On GTK things are working as expected.

By the way, this is likely a widget bug instead of a DOM bug but I will wait until we know what is happening before changing the component.

(and this is not a follow-up from HTML5 Forms but from a progress element related bug)
No longer blocks: 344614
Hardware: x86 → All
On Mac, using a Nightly, the testcase works well.
This bug is indeed reproducible on Windows 7 using Firefox 8. Very likely using a Nightly too.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I think what is wrong here is that the chunk position is computed using the bar size so if the bar size increases, the chunk position moves (goes a bit behind actually) which gives this weird behavior.
Blocks: 641517
Component: DOM: Core & HTML → Widget: Win32
OS: Windows 7 → All
QA Contact: general → win32
Summary: progress elements incorectly refreshes on value change → progress elements incorectly refreshes on value change on Windows
Version: 8 Branch → Trunk

Updated

6 years ago
Depends on: 726144

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 661364

Updated

5 years ago
No longer depends on: 726144

Updated

5 years ago
Blocks: 726144
You need to log in before you can comment on or make changes to this bug.