Last Comment Bug 711993 - Check to make sure we have a valid URI in PermissionsHelper observer
: Check to make sure we have a valid URI in PermissionsHelper observer
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All Android
: P2 normal (vote)
: Firefox 12
Assigned To: :Margaret Leibovic
:
: Sebastian Kaspari (:sebastian)
Mentors:
: 716979 (view as bug list)
Depends on: 706876
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-19 07:48 PST by :Margaret Leibovic
Modified: 2016-07-29 14:21 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (1.21 KB, patch)
2012-01-12 13:35 PST, :Margaret Leibovic
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description :Margaret Leibovic 2011-12-19 07:48:50 PST
We're getting an error on about: pages. For Permissions:Get, we should probably just return an empty permissions array in this case, and for Permissions:Clear, we can just return.
Comment 1 :Margaret Leibovic 2012-01-12 10:55:47 PST
*** Bug 716979 has been marked as a duplicate of this bug. ***
Comment 2 :Margaret Leibovic 2012-01-12 10:57:54 PST
Upping to P2, since bug 716979 is a dupe.
Comment 3 :Margaret Leibovic 2012-01-12 13:35:44 PST
Created attachment 588172 [details] [diff] [review]
patch

Actually, this bug is wrong as described. The only thing that will throw an exception is getting the host on an invalid URI. Also, we don't need to worry about fixing anything in the Permissions:Clear handler, because if we never got permissions in Permissions:Get because of a bad URI, clearPermission will never even get called.

The host string here is only used for display in the dialog title, so I figured we could just use the spec instead. Once bug 711774 is fixed, this won't even be an issue anymore because we'll never even end up enabling the menuitem for these bad URIs.
Comment 5 Marco Bonardo [::mak] 2012-01-14 01:49:42 PST
https://hg.mozilla.org/mozilla-central/rev/40993c4c18d0
Comment 6 :Margaret Leibovic 2012-01-15 08:44:06 PST
Comment on attachment 588172 [details] [diff] [review]
patch

[Approval Request Comment]
Low-risk. This catches an exception you can run into on about: pages.
Comment 7 Alex Keybl [:akeybl] 2012-01-16 13:08:20 PST
Comment on attachment 588172 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 8 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-16 22:40:35 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/148296d69323

Note You need to log in before you can comment on or make changes to this bug.