tumblr web fonts don't work on Firefox

RESOLVED WORKSFORME

Status

Tech Evangelism
Desktop
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Amir Aharoni, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:10.0a2) Gecko/20111218 Firefox/10.0a2
Build ID: 20111218042032

Steps to reproduce:

This blog about Kim Jong Il went viral today: http://kimjongillookingatthings.tumblr.com/about

The about page suggests readers to use Safari or Android because Firefox doesn't load the web font correctly. As a matter of fact, Firefox is the only browser that implements the relevant standard correctly ( http://www.w3.org/TR/css3-fonts/#same-origin-restriction ), and Tumblr admins should fix this bug by changing their web server configuration to allow loading the fonts from a different domain.


Actual results:

The title "kim jong-il looking at things" was shown in Arial font because Firefox couldn't load the font from a different domain.


Expected results:

The title "kim jong-il looking at things" must appear in the Amaranth font. It will be possible if Tumblr will change their server configuration.

Comment 1

6 years ago
Created attachment 582879 [details]
screenshot (Firefox Aurora 10, Chromium)

Comment 2

6 years ago
See also: http://getsatisfaction.com/tumblr/topics/firefox_doesnt_load_web_fonts_font_face_on_tumblr_solution
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

6 years ago
Tumblr is a big player in the free blog hosting area. Do you know about other sites there which can't show webfonts because of this issue?

See also: 
• https://aharoni.wordpress.com/2012/01/31/kim-jong-il-tumblr-webfonts-and-firefox/https://developer.mozilla.org/en/http_access_control

Comment 4

4 years ago
Is this fixed by Tumblr meanwhile?

If not, they will also fail soon with Chrome 37, because Chromes behaviour is fixed and will follow the spec as Firefox and IE 10+ do. 

http://crbug.com/286681
https://groups.google.com/a/chromium.org/forum/#!topic/blink-dev/sU138vJ_PI0

Comment 5

3 years ago
They now use BebasNeueRegular and it is working.
Assignee: english-us → nobody
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Component: English US → Desktop
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.