Last Comment Bug 712202 - GC: add type information to HeapValue writeBarrierPost edge pointer
: GC: add type information to HeapValue writeBarrierPost edge pointer
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal with 1 vote (vote)
: ---
Assigned To: Terrence Cole [:terrence]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: 673454
  Show dependency treegraph
 
Reported: 2011-12-19 18:21 PST by Terrence Cole [:terrence]
Modified: 2012-08-24 17:01 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1: This is not actually used anywhere yet. (2.34 KB, patch)
2011-12-19 18:21 PST, Terrence Cole [:terrence]
no flags Details | Diff | Splinter Review

Description Terrence Cole [:terrence] 2011-12-19 18:21:54 PST
Created attachment 583040 [details] [diff] [review]
v1: This is not actually used anywhere yet.

HeapValue cannot match the HeapPtr interface here, since we cannot dereference a value as a void*: we need to go through toGCThing() to get the targetted object.
Comment 1 Bill McCloskey (:billm) 2011-12-27 09:25:52 PST
Comment on attachment 583040 [details] [diff] [review]
v1: This is not actually used anywhere yet.

Let's wait on this.
Comment 2 Terrence Cole [:terrence] 2012-08-24 17:01:36 PDT
This got fixed at some point in a different bug.

Note You need to log in before you can comment on or make changes to this bug.