Closed Bug 712328 Opened 11 years ago Closed 4 years ago

Addon removal not synced if Firefox was not restarted to complete install

Categories

(Firefox :: Sync, defect)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mihaelav, Unassigned)

References

Details

(Whiteboard: [sync:addons])

Attachments

(1 file)

Mozilla/5.0 (Windows NT 6.1; rv:11.0a1) Gecko/20111220 Firefox/11.0a1

Addon removal is not correctly synced to other device if Firefox was not restarted to complete install

Steps to reproduce:
1. Install 2 add-ons on device A (Addblock and NoScript)
2. Sync both devices => both add-ons are added to device B but restart is needed to finish the install
3. On device B do not restart Firefox
4. On device A, remove an add-on (remove Adblock)and restart Firefox
5. Sync both devices => both add-ons still appear and restart is needed to finish install
6. Restart Firefox on device B

Actual result: The removed add-on (Addblock) is installed on device B and appears in Addons Manager

Expected result: The removed add-on (Addblock) should be removed and no longer appear on device B
This /might/ be related to bug 710448. I'm having trouble reading the zip file contents (are you using a newer version of the zip protocol that isn't supported by UNIX tools), so I can't confirm from the logs.

Does this issue reproduce reliably or just some of the time?

Regardless, I think the scenario described in the STR would be a good TPS test addition.
No longer blocks: 534956
(In reply to Gregory Szorc [:gps] from comment #1)
> Does this issue reproduce reliably or just some of the time?
> 
For me, it reproduced every time I tried
I think this is quite likely related to 710448.
Blocks: 710448
I was just implementing the TPS test for this and realized it isn't trivial because TPS doesn't currently support running 2 Firefox instances in parallel.

That being said, I might be able to tackle this with an xpcshell test. And, there could be teeth to this bug since the code to handle the state of non-restartless add-ons inside the addons engine is a little funky.
Assignee: nobody → gps
Status: NEW → ASSIGNED
I am still seeing this with s-c build of 20120125
No longer blocks: 710448
Depends on: 710448
Whiteboard: [sync:addons]
Assignee: gps → nobody
Component: Firefox Sync: Backend → Sync
Product: Cloud Services → Firefox
No assignee, updating the status.
Status: ASSIGNED → NEW
No assignee, updating the status.
Now we are in a webext-only world, this can die
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.