Files in the process of being downloaded have strange filenames

VERIFIED DUPLICATE of bug 60203

Status

Core Graveyard
File Handling
--
trivial
VERIFIED DUPLICATE of bug 60203
18 years ago
2 years ago

People

(Reporter: Greg K., Assigned: Bill Law)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; N; PPC; en-US; 0.8.1) Gecko/20010306
BuildID:    2001030608

Files that are in the process of being downloaded by Mozilla are given strange
8-character filenames, presumably the same filename they'd be given were they in
the cache, and presumably to ensure said filename is unique.

This is probably okay for files in the cache, but when the user sees these
strange filenames show up in their specify Downloaded Files directory, confusion
may ensue.  Additionally, although Mozilla sometimes renames the file to what it
was intended to be once download is complete, this does not always occur and so
users are left searching for files with the same type or extension.

This bug is a request for enhancement to properly name files that are in the
process of being downloaded.

Reproducible: Always
Steps to Reproduce:
Click on a link that causes Mozilla to download a file to disk at the user's
specifed Downloaded Files path.

Actual Results:  The incoming data is saved to a file with a seemingly random
8-character string as a filename, possibly followed by a dot-extended file type
identifier.

Expected Results:  Mozilla should save the file to the name it has on the server
being accessed (and in the link being clicked).

There are better ways to handle duplicating file names in such situations. For
example, testing for duplication and if encountered appending the number 2 to
the end of the file name.

Thus, a second attempt to download the file "foobar.png" would result in the
file "foobar2.png" or, as happens under Mac OS, "foobar.png 2".

Comment 1

18 years ago
yeah.  its called "salting".  I hate it too.  Lets see what bill and scott 
think.
Assignee: dougt → law
(Assignee)

Comment 2

18 years ago
I think I'm sick of looking at these bugs!

First, we have somebody complain that we should download in the background.  So
we do that.

Then, somebody complains because when they save to the temp dir where that's
happening, they see the file already there and get confused.  So we salt the
file names.

Then, somebody complains that we shouldn't download in the background at all
(partly because we then have to salt the file names).

Now, a complaint that we shouldn't salt the file names.

If we could figure out how to make *all* these people happy simultaneously, it
would be a miracle.

See bug 55690.
Target Milestone: --- → Future
(Reporter)

Comment 3

18 years ago
Thanks for the pointer, Law. It appears I've duplicated bug #60203 with this one.

*** This bug has been marked as a duplicate of 60203 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: tever → benc

Comment 4

17 years ago
->file handling.
Component: Networking: File → File Handling
Keywords: verifyme
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED

Updated

12 years ago
Keywords: verifyme
QA Contact: benc → greg-bugzilla
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.