Last Comment Bug 712341 - dump in workers doesn't appear in adb
: dump in workers doesn't appear in adb
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Blake Kaplan (:mrbkap) (please use needinfo!)
:
Mentors:
: 713432 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 09:23 PST by Blake Kaplan (:mrbkap) (please use needinfo!)
Modified: 2011-12-27 11:29 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1020 bytes, patch)
2011-12-20 10:36 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
bent.mozilla: review+
Details | Diff | Review
Patch (2.16 KB, patch)
2011-12-26 10:11 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
bent.mozilla: review+
mrbkap: checkin+
Details | Diff | Review

Description Blake Kaplan (:mrbkap) (please use needinfo!) 2011-12-20 09:23:39 PST
Patch forthcoming.
Comment 1 Blake Kaplan (:mrbkap) (please use needinfo!) 2011-12-20 10:36:23 PST
Created attachment 583215 [details] [diff] [review]
Patch
Comment 2 Philipp von Weitershausen [:philikon] 2011-12-25 05:07:36 PST
*** Bug 713432 has been marked as a duplicate of this bug. ***
Comment 3 Blake Kaplan (:mrbkap) (please use needinfo!) 2011-12-26 10:11:55 PST
Created attachment 584334 [details] [diff] [review]
Patch
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2011-12-26 20:42:16 PST
Comment on attachment 584334 [details] [diff] [review]
Patch

r=me.

I really wish we could figure out how to redirect stderr... Otherwise we're just going to litter this crap all over the project.
Comment 5 Kyle Machulis [:kmachulis] [:qdot] 2011-12-27 00:28:52 PST
According to 

http://developer.android.com/guide/developing/tools/adb.html

You should be able to do

$ adb shell stop
$ adb shell setprop log.redirect-stdio true
$ adb shell start

To redirect stdout/stderr. But I played with that and it didn't seem to fix this.
Comment 6 Blake Kaplan (:mrbkap) (please use needinfo!) 2011-12-27 02:00:47 PST
Comment on attachment 584334 [details] [diff] [review]
Patch

https://hg.mozilla.org/integration/mozilla-inbound/rev/c4cc8984c02e
Comment 7 Matt Brubeck (:mbrubeck) 2011-12-27 11:29:20 PST
https://hg.mozilla.org/mozilla-central/rev/c4cc8984c02e

Note You need to log in before you can comment on or make changes to this bug.