div with overflow:auto (scrollbars) doesn't respond to zindex

VERIFIED DUPLICATE of bug 14691

Status

()

Core
DOM
VERIFIED DUPLICATE of bug 14691
18 years ago
18 years ago

People

(Reporter: Jeremy Rempel, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; 0.8) Gecko/20010215
BuildID:    20010306

When you specify a DIV element and use the CSS property overflow:auto to show
scrollbars, it no longer responds to zindex. The border of the DIV element does
but not the actual content.

Reproducible: Always
Steps to Reproduce:
make a page w/ a div element. Set a explict size, width & position. Put enough
stuff into the DIV that scrollbars appear and then position another element
directly on top of it.

Expected Results:  Div element should go underneath others.
Jeremy, do you have an example page you could attach by any chance?  Also, could
you try enabling the new viewmanager [
user_pref("nglayout.debug.enable_scary_view_manager", true); ] and seeing
whether that helps? (the old viewmanager has known bugs with positioned elements).
Jeremy, the attached testcase renders exactly the way it's supposed to for me
with builds 2001-03-05-08 and 2001-03-07-14, old and new viewmanagers both, on
Linux.

Comment 4

18 years ago
changing qa contact
QA Contact: janc → desale
(Reporter)

Comment 5

18 years ago
Created attachment 27125 [details]
main htm file
(Reporter)

Comment 6

18 years ago
Created attachment 27126 [details]
style sheet file
(Reporter)

Comment 7

18 years ago
Created attachment 27128 [details]
JS file
Created attachment 27228 [details]
Version oh HTML file that can be loaded right from bugzilla (points to css and js in bugzilla)
Jeremy, I see the problem in your testcase (div does not disappear when you
switch tabs).  The problem is only there with the old viewmanager.  With the new
viewmanager (put user_pref("nglayout.debug.enable_scary_view_manager", true); in
your prefs.js file to try the new viewmanager) the page renders correctly.

See bug 39621 for the status of the new viewmanager, but the summary is that it
should be turned on by default any day now.

*** This bug has been marked as a duplicate of 14691 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
VERIFIED dup
new view manager will be turned on after 0.8.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.