Last Comment Bug 712380 - Add support for clobbering the Android resources when needed
: Add support for clobbering the Android resources when needed
Status: RESOLVED FIXED
[fennec-aurora]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Linux
: P3 normal (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-20 11:54 PST by Mark Finkle (:mfinkle) (use needinfo?)
Modified: 2012-01-25 20:34 PST (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
patch (13.70 KB, patch)
2011-12-20 14:09 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
Details | Diff | Splinter Review
patch v.2 (20.20 KB, patch)
2011-12-21 16:53 PST, Brad Lassey [:blassey] (use needinfo?)
doug.turner: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review
patch for aurora (17.07 KB, patch)
2012-01-20 17:10 PST, Brad Lassey [:blassey] (use needinfo?)
no flags Details | Diff | Splinter Review
patch for aurora (16.99 KB, patch)
2012-01-24 23:31 PST, Brad Lassey [:blassey] (use needinfo?)
doug.turner: review+
doug.turner: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Mark Finkle (:mfinkle) (use needinfo?) 2011-12-20 11:54:09 PST
Right now, when we change or rename an Android drawable in the resources folder, a clobber is sometimes required.

Can we get the makefiles to clear out the resources?
Comment 1 Sriram Ramasubramanian [:sriram] 2011-12-20 13:09:01 PST
Here are few places where clobbering is needed regarding drawables:

1. If we are changing a drawable file, (like a different shape for tabs-button -- with same file name), -- build will succeed, but old image will be used.
2. If we are changing a drawable file completely to a different extension (like repeating a tabs.png in a tabs.xml -- where tabs.png was existing so long) -- build will fail saying "resource already exists"
3. If we are changing a drawable file with a better quality resource (like providing a drawable-hdpi/ or a drawable-xhdpi/ version of a file in drawable/ folder) -- build will succeed, but drawable/ file will be getting used.
Comment 2 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 14:09:28 PST
Created attachment 583288 [details] [diff] [review]
patch

this fixed (for me) the issue that mfinkle and I were discussing when he filed this bug
Comment 3 Brad Lassey [:blassey] (use needinfo?) 2011-12-20 23:32:34 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ac9fac23227a
Comment 4 Ed Morley [:emorley] 2011-12-21 03:32:24 PST
Backed out for intermittent native build failures:
https://tbpl.mozilla.org/?tree=Mozilla-Inbound&rev=ac9fac23227a
https://tbpl.mozilla.org/php/getParsedLog.php?id=8082349&tree=Mozilla-Inbound
{
/builds/slave/m-in-andrd/build/obj-firefox/config/nsinstall -D res/layout
/builds/slave/m-in-andrd/build/obj-firefox/config/nsinstall: cannot change mode of /builds/slave/m-in-andrd/build/obj-firefox/mobile/android/base/res/layout/autocomplete_list_item.xml: No such file or directory
/builds/slave/m-in-andrd/build/obj-firefox/config/nsinstall: cannot change mode of /builds/slave/m-in-andrd/build/obj-firefox/mobile/android/base/res/layout/autocomplete_list_item.xml: No such file or directory
make[6]: *** [res/layout/autocomplete_list_item.xml] Error 1
}

https://hg.mozilla.org/integration/mozilla-inbound/rev/c78f7c5e1736
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2011-12-21 16:53:24 PST
Created attachment 583682 [details] [diff] [review]
patch v.2

also pushed to try https://tbpl.mozilla.org/?tree=Try&rev=80afd447c97d
Comment 6 Mozilla RelEng Bot 2011-12-21 21:51:39 PST
Try run for 80afd447c97d is complete.
Detailed breakdown of the results available here:
    https://tbpl.mozilla.org/?tree=Try&rev=80afd447c97d
Results (out of 3 total builds):
    success: 3
Builds (or logs if builds failed) available at:
http://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/blassey@mozilla.com-80afd447c97d
Comment 7 Doug Turner (:dougt) 2011-12-23 13:43:45 PST
Comment on attachment 583682 [details] [diff] [review]
patch v.2

Review of attachment 583682 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me

make sure things continue to build
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2011-12-23 13:44:32 PST
(In reply to Doug Turner (:dougt) from comment #7)
> Comment on attachment 583682 [details] [diff] [review]
> patch v.2
> 
> Review of attachment 583682 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> rs=me
> 
> make sure things continue to build

see comment 6 for the all green try run
Comment 9 Phil Ringnalda (:philor) 2011-12-24 21:57:18 PST
https://hg.mozilla.org/mozilla-central/rev/56ceeff7cfb8
Comment 10 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 23:15:27 PST
Brad - Do we need this on Aurora? I am thinking we could skip it unless there is an infra/build reason we might want it.
Comment 11 Brad Lassey [:blassey] (use needinfo?) 2012-01-08 13:24:30 PST
No, not needed on Aurora, though we may want it to avoid merge conflicts
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-17 06:34:03 PST
Comment on attachment 583682 [details] [diff] [review]
patch v.2

[Approval Request Comment]
this patch has created a merge problem for landing more patches onto aurora. I'm afraid we need to take this patch just to get the Makefile.in changes.
Comment 13 Alex Keybl [:akeybl] 2012-01-18 08:26:33 PST
Comment on attachment 583682 [details] [diff] [review]
patch v.2

[Triage Comment]
Mobile only - approved for aurora.
Comment 14 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 17:10:59 PST
Created attachment 590396 [details] [diff] [review]
patch for aurora

need to split out the sync-related changes since it hasn't landed on aurora yet
Comment 15 Brad Lassey [:blassey] (use needinfo?) 2012-01-24 23:31:30 PST
Created attachment 591375 [details] [diff] [review]
patch for aurora

[Approval Request Comment]
This is just build clean up. The full patch has been on m-c for a while and several later patches depend on it.

The risk of not taking it is having to rebase several other patches.

When sync lands the rest of this should land with it.
Comment 16 Doug Turner (:dougt) 2012-01-25 08:56:33 PST
Comment on attachment 591375 [details] [diff] [review]
patch for aurora

Review of attachment 591375 [details] [diff] [review]:
-----------------------------------------------------------------

keep it building!
Comment 17 Richard Newman [:rnewman] 2012-01-25 17:55:54 PST
I will be landing this with my Aurora uplift today, assuming I got the merge right.
Comment 18 Richard Newman [:rnewman] 2012-01-25 20:34:21 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/699a36336685

Note You need to log in before you can comment on or make changes to this bug.