[Galaxy Nexus] Excess lines in favicon and reload button on XHDPI devices

RESOLVED FIXED in Firefox 12

Status

Fennec Graveyard
General
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: tchung, Assigned: mbrubeck)

Tracking

Firefox 9
Firefox 12
ARM
Android

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 583345 [details]
URL lines screenshot

on ICS, there's an extra horizontal line in the favicon and reload button.  see screenshot.

doesnt affect honeycomb or gingerbread

see screenshot

Repro:
1) install Firefox 9 on ICS device, Galaxy Nexus
2) verify a horizontal line in the UI

Expected:
- no horiz lines
(Assignee)

Comment 1

6 years ago
It looks like this happens on any device with a >300dpi screen, like the Galaxy Nexus.  It happens because the background images for the urlbar endcaps are not positioned correctly.
Assignee: nobody → mbrubeck
status-firefox10: --- → affected
status-firefox11: --- → affected
status-firefox9: --- → affected
Summary: [ICS] Excess lines in favicon and reload button → [Galaxy Nexus] Excess lines in favicon and reload button on XHDPI devices
(Assignee)

Comment 2

6 years ago
Created attachment 583354 [details] [diff] [review]
patch

The gingerbread theme background images aren't big enough to cover the whole endcaps on XHDPI devices.  This fixes it so they blend nicely with the background color when that happens.

Also requesting approval to take this mobile-only CSS fix for Aurora 11 and Beta 10.  This fixes an ugly UI glitch in the main XUL Fennec UI on some newer devices.
Attachment #583354 - Flags: review?(mark.finkle)
Attachment #583354 - Flags: approval-mozilla-beta?
Attachment #583354 - Flags: approval-mozilla-aurora?
Comment on attachment 583354 [details] [diff] [review]
patch

r+, but I'd like to know why you are changing the colors?
Attachment #583354 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 4

6 years ago
(In reply to Mark Finkle (:mfinkle) from comment #3)
> Comment on attachment 583354 [details] [diff] [review]
> patch
> 
> r+, but I'd like to know why you are changing the colors?

The colors didn't match the images on gingerbread.  (I think they were left over from the froyo theme.)  On high-dpi devices where the background did not cover the whole endcap, the mismatch caused dark areas outside the image boundaries.
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b267a9aab1db
Status: NEW → ASSIGNED
status-firefox12: --- → fixed
status-firefox8: --- → wontfix
status-firefox9: affected → wontfix
Target Milestone: --- → Firefox 12

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/b267a9aab1db
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 7

6 years ago
Comment on attachment 583354 [details] [diff] [review]
patch

[triage comment]
Approved for aurora and beta. UI polish, trivial patch, low risk / mobile-only. Please land as soon as possible
Attachment #583354 - Flags: approval-mozilla-beta?
Attachment #583354 - Flags: approval-mozilla-beta+
Attachment #583354 - Flags: approval-mozilla-aurora?
Attachment #583354 - Flags: approval-mozilla-aurora+
(Assignee)

Comment 8

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e08be766bdba
https://hg.mozilla.org/releases/mozilla-beta/rev/5d3f97f6272c
status-firefox10: affected → fixed
status-firefox11: affected → fixed

Updated

6 years ago
Duplicate of this bug: 713259
(Reporter)

Comment 10

6 years ago
Verified fix on 10b2.  Mozilla/5.0 (Android; Linux armv7l; rv:10.0 Gecko/2011011228 Firefox/10.0 Fennec/10.0
status-firefox10: fixed → verified
(Assignee)

Updated

6 years ago
Duplicate of this bug: 712015
You need to log in before you can comment on or make changes to this bug.