Closed Bug 712526 Opened 8 years ago Closed 8 years ago

Tabs menu screen covers the entire screen

Categories

(Firefox for Android :: General, defect, P4)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 12
Tracking Status
firefox13 --- verified
fennec 11+ ---

People

(Reporter: tchung, Assigned: sriram)

References

Details

(Keywords: uiwanted, Whiteboard: tabs-ux)

Attachments

(3 files)

Attached image screenshot portrait
When greater than 5 tabs open, the new UX displays over the entire Screen, completely covering up Firefox.

See screenshots.  

REpro:
1) install 12-20-2011, 12.0a1 fennec nightly.  SGS2 and Galaxy Nexus
2) open > 5 tabs
3) click the tab drop marker to open the tabs
3) verify tab menu covers the entire viewport of the screen

Expected:
- not a full screen tab menu, with some space at the bottom

ActuaL:
- full screen view
Attached image screenshot landscape
I think that works as intended. Just as long as you can scroll through the list and back out of the panel.

CC'ing :sriram, :ibarlow for clarification
Actually, we only want the tab menu to cover about 2/3 of the screen, so it doesn't feel like you're completely switching contexts when you open the tab menu
Duplicate of this bug: 700950
Assignee: nobody → ibarlow
Keywords: uiwanted
Priority: -- → P4
Duplicate of this bug: 715217
tracking-fennec: --- → ?
tracking-fennec: ? → 11+
Just a friendly ping to try and keep this bug moving along - Devs, do you need any more information from UX to proceed?
Assignee: ibarlow → bnicholson
Assignee: bnicholson → sriram
Attached patch PatchSplinter Review
This patch restricts the height of the tabs menu.
It tries to set a height of 2/3 of the screen. If the list's visible height is a direct multiple of X number of list items, then an additional 1/3rd of the item is shown - to show a perception that there is more in the list. -- This is as per UX team's requirement.
Attachment #591160 - Flags: review?(mark.finkle)
Attachment #591160 - Flags: review?(mark.finkle) → review+
Whiteboard: tabs-ux
https://hg.mozilla.org/mozilla-central/rev/4df33078d5d0
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Sriram, request approval for aurora
Comment on attachment 591160 [details] [diff] [review]
Patch

[Approval Request Comment]
User impact if declined: 
The tabs menu will occupy the entire screen and the user will lose context of what he is doing. The UX team wants this to be available for release on high priority.

Testing completed (on m-c, etc.): Landed on m-c on 01/28

Risk to taking this patch (and alternatives if risky):
The risk is very low as it just alters the height of the tabs menu. There wouldn't be any crashes of any sort due to this.
Attachment #591160 - Flags: approval-mozilla-aurora?
Attachment #591160 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified on:
Nightly Fennec 13.0a1 (2012-03-05)
Device: HTC Desire Z
OS: Android 2.3.3
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.