Last Comment Bug 712581 - Display the property details in the debugger using transitions
: Display the property details in the debugger using transitions
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: P3 enhancement (vote)
: Firefox 13
Assigned To: Victor Porof [:vporof][:vp]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 01:57 PST by Panos Astithas [:past] (away until 7/21)
Modified: 2012-02-27 01:14 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
v1 (2.09 KB, patch)
2012-02-23 08:03 PST, Victor Porof [:vporof][:vp]
past: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] (away until 7/21) 2011-12-21 01:57:11 PST
It would be nice to use some sort of transition effect when opening the properties of an object, or showing the contents of a scope in the property view. Sliding from the top into view when appearing and sliding back into the object when disappearing would be best, I think.
Comment 1 Victor Porof [:vporof][:vp] 2012-02-23 04:27:25 PST
Would this be put in debugger css or themes css?
Comment 2 Panos Astithas [:past] (away until 7/21) 2012-02-23 05:58:15 PST
Theme, since this is something that theme addons might want to modify.
Comment 3 Victor Porof [:vporof][:vp] 2012-02-23 08:03:11 PST
Created attachment 600024 [details] [diff] [review]
v1
Comment 4 Panos Astithas [:past] (away until 7/21) 2012-02-23 08:34:06 PST
Comment on attachment 600024 [details] [diff] [review]
v1

Review of attachment 600024 [details] [diff] [review]:
-----------------------------------------------------------------

I like it. The transition from open to closed doesn't happen for me though.
Comment 5 Victor Porof [:vporof][:vp] 2012-02-23 09:30:55 PST
(In reply to Panos Astithas [:past] from comment #4)
> Comment on attachment 600024 [details] [diff] [review]
> v1
> 
> Review of attachment 600024 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I like it. The transition from open to closed doesn't happen for me though.

I may be missing something, but don't think I can create an animation (or transition for that matter) from open to closed because we're using display: none, which is applied before the animation would start. I can't workaround to using visibility: hidden/visible, because that would leave empty space, and setting element.hidden = true isn't a viable solution because tons of css will need to be changed (and it also doesn't work with display: -moz-box). In all cases, I'd still be required to hack around in js with animationstart/animationend or transitioned events to set display: none or .hidden = true at some point, which I believe would overcomplicate things a bit too much.
Is having just a "in" and no "out" animation too bad?
Comment 6 Panos Astithas [:past] (away until 7/21) 2012-02-23 09:55:01 PST
(In reply to Victor Porof from comment #5)
> (In reply to Panos Astithas [:past] from comment #4)
> > Comment on attachment 600024 [details] [diff] [review]
> > v1
> > 
> > Review of attachment 600024 [details] [diff] [review]:
> > -----------------------------------------------------------------
> > 
> > I like it. The transition from open to closed doesn't happen for me though.
> 
> I may be missing something, but don't think I can create an animation (or
> transition for that matter) from open to closed because we're using display:
> none, which is applied before the animation would start. I can't workaround
> to using visibility: hidden/visible, because that would leave empty space,
> and setting element.hidden = true isn't a viable solution because tons of
> css will need to be changed (and it also doesn't work with display:
> -moz-box). In all cases, I'd still be required to hack around in js with
> animationstart/animationend or transitioned events to set display: none or
> .hidden = true at some point, which I believe would overcomplicate things a
> bit too much.

Yep, that's what I was afraid.

> Is having just a "in" and no "out" animation too bad?

My gut reaction was "hell no", but I can see how someone might find it strictly worse than how it is now. Still, I would prefer to get this in, so that others can form an opinion based on experience.
Comment 7 Victor Porof [:vporof][:vp] 2012-02-23 10:13:18 PST
That's what I also thought. I don't have anything else to add to this, so you could make this into an r+ if you feel like it.
Comment 8 Panos Astithas [:past] (away until 7/21) 2012-02-23 10:46:29 PST
Comment on attachment 600024 [details] [diff] [review]
v1

(In reply to Victor Porof from comment #7)
> That's what I also thought. I don't have anything else to add to this, so
> you could make this into an r+ if you feel like it.

Done. I'll land it tomorrow, if nobody beats me to it.
Comment 9 Rob Campbell [:rc] (:robcee) 2012-02-24 06:51:21 PST
https://hg.mozilla.org/integration/fx-team/rev/ccac5b7ae380
Comment 10 Tim Taubert [:ttaubert] 2012-02-27 01:14:22 PST
https://hg.mozilla.org/mozilla-central/rev/ccac5b7ae380

Note You need to log in before you can comment on or make changes to this bug.