Closed Bug 712588 Opened 8 years ago Closed 8 years ago

Clear location not available in "Clear Site Settings"

Categories

(Firefox for Android :: General, defect, P2)

11 Branch
ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 11
Tracking Status
firefox11 --- verified
firefox12 --- verified
fennec 11+ ---

People

(Reporter: camelia.urian, Assigned: Margaret)

References

Details

Attachments

(1 file)

Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20111220 Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Nexus S
OS: Android 2.3

Steps to reproduce:
1. Go to html5demos.com/geo
2. On the door hanger select "Share".
3. Repeat steps 1 and 2: 6 times. ->A permanent permission was saved, so after the 6th time door hanger is not displayed any more.
4. Go to Menu->More->Clear Site Settings

Expected results:
 Prompt for clear site settings is displayed with "Share" option checked and buttons "Clear" and "Cancel"

Actual results: 
 Prompt for clear site settings is displayed, but it say "There are no settings to clear".
Assignee: nobody → margaret.leibovic
Priority: -- → P2
Attached patch patchSplinter Review
Ugh, desktop uses "geo" as the permission type, but mobile uses "geolocation".

I quickly looked into other places where my assumptions about what we do may be wrong, and it looks like on mobile we use testExactPermission for all permission types (instead of testPermission), so I'll file another bug on changing that.
Attachment #583884 - Flags: review?(mark.finkle)
(In reply to Margaret Leibovic [:margaret] from comment #1)

> I quickly looked into other places where my assumptions about what we do may
> be wrong, and it looks like on mobile we use testExactPermission for all
> permission types (instead of testPermission), so I'll file another bug on
> changing that.

I filed bug 713062 about this.
Attachment #583884 - Flags: review?(mark.finkle) → review+
Attachment #583884 - Flags: approval-mozilla-aurora?
Comment on attachment 583884 [details] [diff] [review]
patch

[Triage Comment]
Approving this mobile fix for Aurora.
Attachment #583884 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/d615fb458ae4
Blocks: 706876
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Version: Firefox 12 → Firefox 11
re-opened for m-i to m-c landing
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
nm, needs aurora landing
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Verified Fixed on m-c
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20111230 Firefox/12.0a1 Fennec/12.0a1
Target Milestone: Firefox 12 → Firefox 11
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120102 Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Nexus S
OS: Android 2.3

Verified fixed on Aurora too
Status: RESOLVED → VERIFIED
Build ID for previous comment is:
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a2) Gecko/20120103 Firefox/11.0a2 Fennec/11.0a2
tracking-fennec: --- → 11+
You need to log in before you can comment on or make changes to this bug.