Last Comment Bug 712622 - Add support for Shadow DOM
: Add support for Shadow DOM
Status: RESOLVED DUPLICATE of bug 811542
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal with 15 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-21 06:14 PST by Sonny Piers [:sonny]
Modified: 2013-12-10 11:01 PST (History)
37 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Sonny Piers [:sonny] 2011-12-21 06:14:07 PST
http://dvcs.w3.org/hg/webcomponents/raw-file/tip/spec/shadow/index.html

This feature is highly needed for Web applications development.
Comment 1 Olli Pettay [:smaug] 2011-12-21 06:17:58 PST
It is not at all clear whether Web Components will be added to the web platform.
It is probably still as likely that XBL2 will be used instead... all is unclear.
Comment 2 Jeff Griffiths (:canuckistani) (:⚡︎) 2012-10-07 00:15:52 PDT
At this stage it is pretty clear Shadow DOM is a thing - Chrome has shipped it and there is a working draft at the W3C:

http://www.w3.org/TR/2012/WD-shadow-dom-20120522/

Shadow DOM is starting to gain traction with web developers:

http://lanyrd.com/2012/jsconfeu/syxwc/
Comment 3 Olli Pettay [:smaug] 2012-10-07 04:05:14 PDT
(In reply to Jeff Griffiths (:canuckistani) from comment #2)
> At this stage it is pretty clear Shadow DOM is a thing - Chrome has shipped
> it and there is a working draft at the W3C:
Neither of those mean it is a thing.
Chrome has also filesystem API and there is a W3C draft for it, but it isn't a thing.


However, Shadow DOM is a thing :)
Comment 4 diegobfernandez 2013-10-28 11:32:33 PDT
More than a year since last comment!
What about implementing this very useful feature.
There's a lot of good stuff going around Web Components and this is very necessary to go on.

Mozilla has a polifyll for Web Components and it looks like it's desirable to be implemented in core.
However I am not capable of doing this on my own.
Hope my comments starts a discussion on this subject!

Thanks folks
Comment 5 Andrew McCreight [:mccr8] 2013-10-28 11:35:37 PDT
People have been working on it, just not in this bug.  This bug should probably be duped to bug 811542.
Comment 6 diegobfernandez 2013-10-28 14:43:04 PDT
Thanks. I'm glad to see you guys working on it.
I agree this bug should be closed.
Comment 7 Andrew McCreight [:mccr8] 2013-10-28 15:10:04 PDT

*** This bug has been marked as a duplicate of bug 811542 ***

Note You need to log in before you can comment on or make changes to this bug.