NullPointerException at org.mozilla.gecko.GeckoAppShell.notifyIMEEnabled

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
--
critical
VERIFIED FIXED
6 years ago
10 months ago

People

(Reporter: Stewart Campbell, Assigned: blassey)

Tracking

({crash})

Trunk
Firefox 12
ARM
Android
crash
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed)

Details

(Whiteboard: [native-crash], URL)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a2) Gecko/20111220 Firefox/10.0a2
Build ID: 20111220042029

Steps to reproduce:

Start Fennec - Home page renders with checkerboard at the bottom.  As soon as the checkerboard is replaced by the grey background Fennec crashed.


Actual results:

Crashes:

Logcat shows the following:

E/StrictMode( 1427): Finalizing a Cursor that has not been deactivated or closed. database = /data/data/org.mozilla.fennec/files/mozilla/heaacgh1.default/places.sqlite, table = null, query = SELECT places.url AS a_url, places.title AS a_title, history.visit_date AS a_date FROM (moz_historyvisits AS history JOIN moz_places AS places ON places.id = history.place_id) WHERE places.hidden <> 1 ORDER BY history.visit_date DESC
E/StrictMode( 1427): android.database.sqlite.DatabaseObjectNotClosedException: Application did not close the cursor or database object that was opened here
E/StrictMode( 1427):    at android.database.sqlite.SQLiteCursor.<init>(SQLiteCursor.java:238)
E/StrictMode( 1427):    at android.database.sqlite.SQLiteDirectCursorDriver.query(SQLiteDirectCursorDriver.java:51)
E/StrictMode( 1427):    at android.database.sqlite.SQLiteDatabase.rawQueryWithFactory(SQLiteDatabase.java:1539)
E/StrictMode( 1427):    at android.database.sqlite.SQLiteDatabase.rawQuery(SQLiteDatabase.java:1508)
E/StrictMode( 1427):    at org.mozilla.gecko.ProfileMigrator$PlacesTask.migrateHistory(ProfileMigrator.java:185)
E/StrictMode( 1427):    at org.mozilla.gecko.ProfileMigrator$PlacesTask.migratePlaces(ProfileMigrator.java:338)
E/StrictMode( 1427):    at org.mozilla.gecko.ProfileMigrator$PlacesTask.run(ProfileMigrator.java:371)
E/StrictMode( 1427):    at java.lang.Thread.run(Thread.java:1020)
E/SQLiteDatabase( 1427): close() was never explicitly called on database '/data/data/org.mozilla.fennec/files/mozilla/heaacgh1.default/places.sqlite'
E/SQLiteDatabase( 1427): android.database.sqlite.DatabaseObjectNotClosedException: Application did not close the cursor or database object that was opened here
E/SQLiteDatabase( 1427):        at android.database.sqlite.SQLiteDatabase.<init>(SQLiteDatabase.java:1980)
E/SQLiteDatabase( 1427):        at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:977)
E/SQLiteDatabase( 1427):        at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:956)
E/SQLiteDatabase( 1427):        at android.database.sqlite.SQLiteDatabase.openDatabase(SQLiteDatabase.java:932)
E/SQLiteDatabase( 1427):        at org.mozilla.gecko.ProfileMigrator$PlacesTask.openPlaces(ProfileMigrator.java:312)
E/SQLiteDatabase( 1427):        at org.mozilla.gecko.ProfileMigrator$PlacesTask.migratePlaces(ProfileMigrator.java:336)
E/SQLiteDatabase( 1427):        at org.mozilla.gecko.ProfileMigrator$PlacesTask.run(ProfileMigrator.java:371)
E/SQLiteDatabase( 1427):        at java.lang.Thread.run(Thread.java:1020)
I/dalvikvm( 1427): Uncaught exception thrown by finalizer (will be discarded):
I/dalvikvm( 1427): java.lang.IllegalStateException: Don't have database lock!
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase.verifyLockOwner(SQLiteDatabase.java:2131)
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase$1.entryRemoved(SQLiteDatabase.java:2223)
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase$1.entryRemoved(SQLiteDatabase.java:2219)
I/dalvikvm( 1427):      at android.util.LruCache.trimToSize(LruCache.java:197)
I/dalvikvm( 1427):      at android.util.LruCache.evictAll(LruCache.java:285)
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase.deallocCachedSqlStatements(SQLiteDatabase.java:2184)
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase.closeClosable(SQLiteDatabase.java:1096)
I/dalvikvm( 1427):      at android.database.sqlite.SQLiteDatabase.finalize(SQLiteDatabase.java:1950)
I/dalvikvm( 1427):      at dalvik.system.NativeStart.run(Native Method)

AND

I/GeckoApp( 1427): Got message: Gecko:Ready
W/System.err( 1427): java.lang.NullPointerException
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.notifyIMEEnabled(GeckoAppShell.java:502)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:449)
W/System.err( 1427):    at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)
W/System.err( 1427): java.lang.NullPointerException
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.notifyIMEEnabled(GeckoAppShell.java:502)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.nativeRun(Native Method)
W/System.err( 1427):    at org.mozilla.gecko.GeckoAppShell.runGecko(GeckoAppShell.java:449)
W/System.err( 1427):    at org.mozilla.gecko.GeckoThread.run(GeckoThread.java:107)


Expected results:

No Crash

Updated

6 years ago
Severity: normal → critical
Keywords: crash
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Whiteboard: [native-crash]
(Reporter)

Updated

6 years ago
Severity: critical → normal
OS: Android → Windows 7
Hardware: ARM → x86_64

Updated

6 years ago
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712718
Reopening for second crash signature. The first one in profileMigrate is a dupe.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Summary: Crash shortly after starting on Galaxy Tab 10.1 → NullPointerException at org.mozilla.gecko.GeckoAppShell.notifyIMEEnabled
Created attachment 583657 [details] [diff] [review]
patch
Assignee: nobody → blassey.bugs
Attachment #583657 - Flags: review?(doug.turner)

Updated

6 years ago
Attachment #583657 - Flags: review?(doug.turner) → review+
https://hg.mozilla.org/mozilla-central/rev/917a5403d3c6
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Whiteboard: [native-crash] → [native-crash][fennec-aurora]
Duplicate of this bug: 711756
Comment on attachment 583657 [details] [diff] [review]
patch

[Approval Request Comment]
crash fix for aurora
Attachment #583657 - Flags: approval-mozilla-aurora?
status-firefox11: --- → affected
status-firefox12: --- → fixed
Whiteboard: [native-crash][fennec-aurora] → [native-crash]

Comment 7

6 years ago
Comment on attachment 583657 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #583657 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/1ae3a15ae765
status-firefox11: affected → fixed
This crash doesn't reproduce anymore on Nightly and Aurora builds. Closing bug as verified fixed.

Mozilla/5.0 (Android;Linux armv7l;rv:11.0a2)Gecko/20120130
Firefox/11.0a2 Fennec/11.0a2
Device: Samsung Galaxy S
OS: Android 2.2

Mozilla/5.0 (Android;Linux armv7l;rv:12.0a1)Gecko/20120130
Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.