Last Comment Bug 712907 - Assertion failure: lastProperty()->hasTable(), at js/src/jsscope.cpp:493
: Assertion failure: lastProperty()->hasTable(), at js/src/jsscope.cpp:493
Status: RESOLVED FIXED
js-triage-needed
: assertion, testcase
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86 Linux
: -- critical (vote)
: mozilla12
Assigned To: Brian Hackett (:bhackett)
:
Mentors:
Depends on:
Blocks: langfuzz
  Show dependency treegraph
 
Reported: 2011-12-22 03:59 PST by Christian Holler (:decoder)
Modified: 2011-12-24 22:07 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
shell testcase, unpack, chdir and run main.js with options "-n -m" (1.84 KB, application/x-compressed-tar)
2011-12-22 03:59 PST, Christian Holler (:decoder)
no flags Details
patch (551 bytes, patch)
2011-12-23 15:18 PST, Brian Hackett (:bhackett)
luke: review+
Details | Diff | Splinter Review

Description Christian Holler (:decoder) 2011-12-22 03:59:22 PST
Created attachment 583759 [details]
shell testcase, unpack, chdir and run main.js with options "-n -m"

The attached test asserts on mozilla-central revision f98c57415d8d (options -m -n). I assume this test is fragile across architectures (use 32 bit) because it's an OOM (with gcparam though).
Comment 1 Brian Hackett (:bhackett) 2011-12-23 15:18:25 PST
Created attachment 584132 [details] [diff] [review]
patch

The return value of the hashify() call when converting objects to dictionary mode was being ignored.
Comment 2 Brian Hackett (:bhackett) 2011-12-23 18:20:26 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/cf4feabb94cc
Comment 3 Phil Ringnalda (:philor) 2011-12-24 22:07:16 PST
https://hg.mozilla.org/mozilla-central/rev/cf4feabb94cc

Note You need to log in before you can comment on or make changes to this bug.