drawImage crashes Firefox

RESOLVED DUPLICATE of bug 704765

Status

()

Core
Canvas: 2D
RESOLVED DUPLICATE of bug 704765
7 years ago
7 years ago

People

(Reporter: Dionysis Zindros, Unassigned)

Tracking

9 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

642 bytes, text/html
Details
(Reporter)

Description

7 years ago
Created attachment 583777 [details]
Testcase

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.11 (KHTML, like Gecko) Chrome/17.0.963.12 Safari/535.11

Steps to reproduce:

1) Quit Firefox
2) Choose Start -> Run and enter:
firefox http://dionyziz.kamibu.com/particle-firefox/drawimage.html


Actual results:

Firefox crashed


Expected results:

The website should open
(Reporter)

Comment 1

7 years ago
ALWAYS crashes my Firefox 9.0.1 on Windows 7 when run using the run command.

Tried on two other systems with Firefox 9.0.1 on Windows 7 and it does NOT cause a crash.

Tried on a Linux system and it does NOT cause a crash.
(Reporter)

Comment 2

7 years ago
Created attachment 583778 [details]
Updated testcase
Attachment #583777 - Attachment is obsolete: true

Updated

7 years ago
Attachment #583778 - Attachment mime type: text/plain → text/html
Did you try in safe mode? (`firefox -safe-mode http://dionyziz.kamibu.com/particle-firefox/drawimage.html`)
Component: General → Canvas: 2D
Product: Firefox → Core
QA Contact: general → canvas.2d
(Reporter)

Comment 5

7 years ago
I tried safe mode now. Here's what happened: It worked fine in safe mode, then when I restarted the browser WITHOUT safe mode, it worked again. Apparently going into safe mode fixed something, but I didn't change any settings.
Stack signature looks to be a dupe of Bug 704765.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 704765
You need to log in before you can comment on or make changes to this bug.