Closed Bug 712949 Opened 9 years ago Closed 9 years ago

iframe not shown in FF version 9 (www.rtl.nl/financien/ uses "taintEnabled" for browser detection)

Categories

(Tech Evangelism Graveyard :: Dutch, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: John.Kitz, Unassigned)

References

()

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
Build ID: 20111216140209

Steps to reproduce:

Went to a news site (http://www.rtl.nl/financien/rtlz/vandaag/) that I visit frequently.


Actual results:

Most of the HTML is rendered as expected, however an iframe in the center of the page remains white. In addition, in the tab the word "Connecting..." continues to be shown as well as the turning green circle.

The problem coincides with the release of FF version 9 and an upgrade to Java Version 6 Update 30. However, since this is the only site that I visit that has this problem I suspect FF Release 9.


Expected results:

The large white rectangle should have contained stock exchange data.
Confirmed on Firefox 9.0.1 to Nightly12.0a1. 

#1 For Firefox9.0.1
http://hg.mozilla.org/releases/mozilla-release/rev/c4405d7a95f6
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 ID:20111220165912

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/js/dbAandelen.js
Line: 108

Error: LS_FqR is not defined
Source file: http://www.quintrics.nl/rtlz/website/ls/lspushpage.js
Line: 9

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/ls/lspushpage.js
Line: 9

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/jq/jquery-1.4.2.min.js
Line: 130

Regression window(m-c)
Works:
http://hg.mozilla.org/mozilla-central/rev/6dc468c41136
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110821 Firefox/9.0a1 ID:20110821030758
Fails:
http://hg.mozilla.org/mozilla-central/rev/482742e6fff7
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110821 Firefox/9.0a1 ID:20110821111959
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=6dc468c41136&tochange=482742e6fff7


Regression window(m-i)
Works:
http://hg.mozilla.org/integration/mozilla-inbound/rev/b727463566a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110820 Firefox/9.0a1 ID:20110820184005
Fails:
http://hg.mozilla.org/integration/mozilla-inbound/rev/857f058efa56
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0a1) Gecko/20110820 Firefox/9.0a1 ID:20110821013315
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=b727463566a1&tochange=857f058efa56
Triggered by:
857f058efa56	Matheus Kerschbaum — Bug 679971 - Remove Navigator.taintEnabled(); r=gal


#2 For Firefox10.0beta
http://hg.mozilla.org/releases/mozilla-beta/rev/c130e43aa4b5
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0) Gecko/20100101 Firefox/10.0 ID:20111221135037

Error: $ is not defined
Source file: http://www.quintrics.nl/rtlz/website/js/dbAandelen.js
Line: 414

Error: LS_FqR is not defined
Source file: http://www.quintrics.nl/rtlz/website/ls/lspushpage.js
Line: 9

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/jq/jquery-1.4.2.min.js
Line: 128

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/ls/lspushpage.js
Line: 9

Error: attempt to run compile-and-go script on a cleared scope
Source file: http://www.quintrics.nl/rtlz/website/jq/jquery-1.4.2.min.js
Line: 130


#3 For Aurora11.0a2 and Nightly12.0a1
http://hg.mozilla.org/releases/mozilla-aurora/rev/e08be766bdba
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a2) Gecko/20111221 Firefox/11.0a2 ID:20111221172848
http://hg.mozilla.org/mozilla-central/rev/ed47a41ba26a
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20111222 Firefox/12.0a1 ID:20111222031055


Error: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIDOMHTMLDocument.writeln]
Source file: http://www.quintrics.nl/rtlz/website/ls/lspushpage.js
Line: 9
Blocks: 679971
Status: UNCONFIRMED → NEW
Component: General → DOM
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → general
> 857f058efa56	Matheus Kerschbaum — Bug 679971 - Remove Navigator.taintEnabled(); r=gal

Sounds like this site is doing broken browser-sniffing?
(In reply to Boris Zbarsky (:bz) from comment #2)
> > 857f058efa56	Matheus Kerschbaum — Bug 679971 - Remove Navigator.taintEnabled(); r=gal
> 
> Sounds like this site is doing broken browser-sniffing?

It works on 9.0.1 to 12.0a1 if I set UA as follows.
user_pref("general.useragent.override", "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7");
Yeah, definitely broken sniffing.

John, can you please report the issue to the site, since you're actually one of their users?
Assignee: nobody → dutch
Component: DOM → Dutch
Product: Core → Tech Evangelism
QA Contact: general → dutch
Version: 9 Branch → unspecified
http://www.quintrics.nl/rtlz/website/ls/lscommons.js

...if((document.childNodes)&&(!document.all)&&(!navigator.taintEnabled) ...
Yeah, and then inside that clause it UA-sniffs different webkit versions..... and fails to detect us as one and then goes off the rails.
OS: Windows XP → All
Hardware: x86 → All
Summary: iframe not shown in FF version 9. → iframe not shown in FF version 9 (www.rtl.nl/financien/ uses "taintEnabled" for browser detection)
> http://www.quintrics.nl/rtlz/website/ls/lscommons.js

quintrics.nl redirects to http://www.sharecompany.nl
So this code is probably not only used on rtl.nl
(In reply to Boris Zbarsky (:bz) from comment #4)
> Yeah, definitely broken sniffing.
> 
> John, can you please report the issue to the site, since you're actually one
> of their users?

Done.

FYI: http://www.w3schools.com/jsref/met_nav_taintenabled.asp suggests pbm. is not limited to FF and found similar bug reported on jQuery site.
Hi,

I'm from the company that wrote the incriminated code. That's indeed a bug in the old version of our libraries; an upgrade to the latest version would solve it.

Sorry for the trouble.
anyway looks like http://www.rtl.nl/financien/rtlz/vandaag/ already did the upgrade so that the issue with that website should be resolved
(In reply to Mone from comment #9)
> Hi,
> 
> I'm from the company that wrote the incriminated code. That's indeed a bug
> in the old version of our libraries; an upgrade to the latest version would
> solve it.
> 
> Sorry for the trouble.

Confirmed that the iframe is now being rendered again. Appreciate it, it's a bit annoying to have to use two browsers. No need to apologize, bugs happen :) In addition based on the comments in this ticket I suggest you interpret this bug report as being helpful to get rid of deprecated code rather than incriminating.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
> anyway looks like http://www.rtl.nl/financien/rtlz/vandaag/ already did the upgrade

Is that based on source inspection?  See below...

If this is a general library, would it be possible for your company to contact past customers and get them to update their installations?  It would be nice to be able to actually remove taintEnabled.

> Confirmed that the iframe is now being rendered again.

That may well be because we backed out bug 679971 because of all the pages that were sniffing for taintEnabled.  :(
Reopening pending answer to first part of comment 12, btw.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
>Is that based on source inspection?
Yes, I took a look to the included file to verify the library version.
I confirm that the current library works as expected on both cases (correct detection / wrong detection) 

>It would be nice to be able to actually remove taintEnabled.
The detection via taintEnabled is still in place but with the result of that detection nothing "important" is executed (on previous versions we used that check to choose between appending an iframe and document.writing it). I'm going to check if I can remove it completely for the next version.

>would it be possible for your company to contact past customers and get them to update their installations?
We always notify our customers to upgrade but obviously we can't force them.
We also distribute a free version, I can't contact users of that version.
(anyway note that the version without the bug was released on 4 Feb 2011 in beta version and on 7 Jun 2011 as final)
Ah, OK.  So pretty recent...

Thanks for confirming that the site is actually fixed!
Status: REOPENED → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.