Last Comment Bug 712959 - Image decoding prefs aren't reloaded when they change
: Image decoding prefs aren't reloaded when they change
Status: RESOLVED FIXED
[qa?]
:
Product: Core
Classification: Components
Component: ImageLib (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Justin Lebar (not reading bugmail)
:
:
Mentors:
Depends on:
Blocks: 676270
  Show dependency treegraph
 
Reported: 2011-12-22 07:58 PST by Justin Lebar (not reading bugmail)
Modified: 2012-03-29 12:42 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed


Attachments
Patch v1 (10.55 KB, patch)
2011-12-22 09:21 PST, Justin Lebar (not reading bugmail)
joe: review+
Details | Diff | Splinter Review

Description Justin Lebar (not reading bugmail) 2011-12-22 07:58:32 PST
There's no good reason for this; just an omission in the pref tracking code.

I'll rewrite the code to use the new pref caches.  It's much cleaner.
Comment 1 Justin Lebar (not reading bugmail) 2011-12-22 09:21:20 PST
Created attachment 583825 [details] [diff] [review]
Patch v1

Review: joedrew!
Comment 2 Justin Lebar (not reading bugmail) 2011-12-22 09:22:28 PST
> Review: joedrew!

Hm, that didn't work quite as I'd intended.  :)
Comment 3 Joe Drew (not getting mail) 2012-01-03 13:55:17 PST
Comment on attachment 583825 [details] [diff] [review]
Patch v1

Review of attachment 583825 [details] [diff] [review]:
-----------------------------------------------------------------

DiscardTracker.cpp |   14 ++++++-
 RasterImage.cpp    |   39 ++++++++++++---------
 RasterImage.h      |    5 --
 imgRequest.cpp     |   94 ++++++-----------------------------------------------
 4 files changed, 45 insertions(+), 107 deletions(-)

Yes, this'll do.

::: image/src/RasterImage.cpp
@@ +86,5 @@
>  #endif
>  
> +// Tweakable progressive decoding parameters.  These are initialized to 0 here
> +// because otherwise, we have to initialize them in a static initializer, which
> +// makes us slower to start up.

All globals are initialized to zero as they're in the .bss section, right?
Comment 4 Justin Lebar (not reading bugmail) 2012-01-03 14:00:58 PST
> All globals are initialized to zero as they're in the .bss section, right?

Yes.  And because the whole page comes in as zeroed, this is faster than initializing to something else.
Comment 5 Justin Lebar (not reading bugmail) 2012-01-03 15:15:12 PST
Thanks, Joe.

https://hg.mozilla.org/integration/mozilla-inbound/rev/e251ac6325b4
Comment 6 Marco Bonardo [::mak] 2012-01-04 04:48:38 PST
https://hg.mozilla.org/mozilla-central/rev/e251ac6325b4
Comment 7 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-03-29 12:42:05 PDT
Is there something QA can do to test this?

Note You need to log in before you can comment on or make changes to this bug.