Last Comment Bug 712990 - Endian issue with YarrJIT
: Endian issue with YarrJIT
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: 12 Branch
: Other All
: -- normal (vote)
: mozilla12
Assigned To: Cameron Kaiser [:spectre]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-22 09:24 PST by Cameron Kaiser [:spectre]
Modified: 2011-12-23 18:59 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Big endian fix for YarrJIT ignoreCase (1.15 KB, patch)
2011-12-22 09:24 PST, Cameron Kaiser [:spectre]
dmandelin: review+
Details | Diff | Splinter Review

Description Cameron Kaiser [:spectre] 2011-12-22 09:24:11 PST
Created attachment 583827 [details] [diff] [review]
Big endian fix for YarrJIT ignoreCase

http://code.google.com/p/tenfourfox/issues/detail?id=120

Although PowerPC JM+TI is currently stillborne -_-, we are making use of our macroassembler for YARR and Ben Stuhl, one of our TenFourFox contributors, discovered an endianness issue with YARR JIT. It's a small patch and I figured we should push it upstream for SPARC and (future) MIPS consumers. Ben's notes:

I built js/ from 10.4Fx 9 and ran 'make check jstests'. It revealed a few failures, including several; in ecma_3/RegExp/perlstress-001.js, which can be reduced to

'A]'.match(/a]/i) == null /* should be 'A]' */

. I get the same result running the test by hand in the Web Console in 10.4Fx 9.

It turns out to be a minor endian bug in YARR; here's a patch.
Comment 1 David Mandelin [:dmandelin] 2011-12-22 11:50:25 PST
Did you file a bug with WebKit too?
Comment 2 Cameron Kaiser [:spectre] 2011-12-22 11:58:36 PST
Not yet, I'll do that too. Thanks for the review!
Comment 3 David Mandelin [:dmandelin] 2011-12-22 19:10:39 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/334f198c10b5
Comment 4 Ed Morley [:emorley] 2011-12-23 18:59:03 PST
https://hg.mozilla.org/mozilla-central/rev/334f198c10b5

Note You need to log in before you can comment on or make changes to this bug.