Html5 manifest and ajax problem

RESOLVED DUPLICATE of bug 713083

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 713083
7 years ago
7 years ago

People

(Reporter: mubeda, Unassigned)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

Use html5 application with manifest support and retrieve a webpage using an ajax call.

$.ajax({
 type: 'GET',
 url: url,
 dataType: 'html',
 beforeSend: function () {
  doOnPageBeforeLoad();
 },
 success: function (response) {
 //console.log(response);
 doOnPageLoadSuccess(response);
 },
 error: function (response) {
   console.log(response);
 },
 complete: function (jqXHR, status, responseText) {
  doOnPageLoadComplete();
 }
});


Actual results:

If remote server is not available, web page is not displayed. Ajax callback returns error. 


Expected results:

Web page should be displayed anyway because it was included in the manifest file. Other web browser supports it. Only works if you had visited the page once (it should works even you did not open it before)

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 713083
You need to log in before you can comment on or make changes to this bug.