Use Asynchronous Favicons API for PlacesUtils.jsm

RESOLVED FIXED in mozilla12

Status

()

Toolkit
Places
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: felix, Assigned: felix)

Tracking

Trunk
mozilla12
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [snappy])

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0.1) Gecko/20100101 Firefox/8.0.1
Build ID: 20111120135848



Actual results:

PlacesUtils.jsm uses sync favicons apis (nsIFaviconService)


Expected results:

PlacesUtils.jsm should use async favicons apis (mozIAsyncFavicons)
(Assignee)

Comment 1

6 years ago
Created attachment 584091 [details] [diff] [review]
Use Asynchronous Favicons API for PlacesUtils.jsm

Summary of Changes:

- setAndLoad -> setAndFetch
- setFaviconData -> replaceFaviconData
- nsIFaviconService -> mozIAsyncFavicons
Attachment #584091 - Flags: review?(mak77)
Component: Form Manager → Places
QA Contact: form.manager → places

Updated

6 years ago
Blocks: 713642

Updated

6 years ago
Assignee: nobody → felix.the.cheshire.cat
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 584091 [details] [diff] [review]
Use Asynchronous Favicons API for PlacesUtils.jsm

Review of attachment 584091 [details] [diff] [review]:
-----------------------------------------------------------------

please get a try run with the patch before pushing, since I'd not want that there is some test relying on the synchronous behavior that needs some fix
Attachment #584091 - Flags: review?(mak77) → review+
any news?
(Assignee)

Comment 4

6 years ago
Just got my commit access amended. Will push this to try and then hopefully to mc tonight...

Comment 6

6 years ago
https://hg.mozilla.org/mozilla-central/rev/cee13e0b2ee4
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla12
Whiteboard: [snappy]
You need to log in before you can comment on or make changes to this bug.