"Get Mail" for Movemail account always adds exactly one line to Threads pane regardless of number of messages (0, 1, more) actually downloaded. This makes "Repair folder" necessary

VERIFIED DUPLICATE of bug 748726

Status

--
major
VERIFIED DUPLICATE of bug 748726
7 years ago
7 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({regression})

Trunk
x86_64
Linux
regression

SeaMonkey Tracking Flags

(seamonkey2.8 unaffected)

Details

Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20111225 Firefox/12.0a1 SeaMonkey/2.9a1 ID:20111225003005

Get new messages for Movemail adds a message (empty AFAICT, no subject, dated 1970-01-01, "View Source" shows nothing, not even headers) to the Local folder where filter "All mail" from the Novemail account. This is a new development in this nightly.

Right-clicking the folder, then "Properties → Repair" removes the spurious message(s), Get mail brings one back.

Tested only (so far) with the corresponding system mailbox /var/spool/mail/root empty.
Additional info:
- With several such "empty messages" in the folder, the "order received" numbers increase 1 by 1 between them.
- When /var/spool/mail/root is *not* empty, the mail appears normally with no bogus message.
- I haven't yet checked if there is a new SeaMonkey nightly dated Dec.26 but if there is, I'll install it soon.
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20111226 Firefox/12.0a1 SeaMonkey/2.9a1 ID:20111226003003

AFAICT, getting Movemail mail when there is none available changes the .msf file but not the mailbox folder itself.
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20111226 Firefox/12.0a1 SeaMonkey/2.9a1 ID:20111227142829

Problem has disappeared, either thanks to the fix for bug 713683, or through some other agency. => WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20111228 Firefox/12.0a1 SeaMonkey/2.9a1 ID:20111228003008

Alas, I resolved this bug too fast: three empty messages are now sitting in the output folder of my Filter "All messages" for Movemail inbox.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: Empty movemail message dated 1970-01-01 → Empty movemail message dated 1970-01-01 when trying to get mail and none is available

Comment 5

7 years ago
tony, do you know when it regressed?
(In reply to Wayne Mery (:wsmwk) from comment #5)
> tony, do you know when it regressed?

The "first bad" nightly was the one mentioned at the top of comment #0. I know because that's when I first saw the problem, and I used to check my Movemail mail every hour, which is more than often enough to catch one email a day from cron-daily, plus one a week from cron-weekly.
P.S. I suspect a regression from the "pluggable store work" mentioned by Bienvenu in bug 713683 comment #3 and #6.

Updated

7 years ago
Blocks: 402392
Severity: normal → major
Even after removing the "All mail" filter on the Movemail inbox, I notice now that "Get mail" adds exactly one message line to the threads pane regardless of how many mails were actually waiting. I need to right-click the Movemail inbox, then "Properties → Repair folder", then "OK" in order to see all individual emails in the thread pane. (On my system, these are emails from cron to root, and I get one each from cron-weekly, cron-daily and cron@reboot.)
altering Summary to describe behaviour more precisely (cf. comment #8)
Summary: Empty movemail message dated 1970-01-01 when trying to get mail and none is available → "Get Mail" for Movemail account always adds exactly one line to Threads pane regardless of number of messages (0, 1, more) actually downloaded. This makes "Repair folder" necessary
could this be another instance of 748726 ?

Comment 11

7 years ago
On my system this bug appears with the update to Thunderbird-12.0

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060909 Thunderbird/1.5.0.7 Mnenhy/0.7.4.666

Comment 12

7 years ago
yes - dupping to that bug, since it has technical discussion of the issue and a wip, though this bug has a better description.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 748726

Comment 13

7 years ago
there will be try server builds with a potential fix here http://ftp.mozilla.org/pub/mozilla.org/thunderbird/try-builds/bienvenu@nventure.com-e4cba7544872 - if you can try them and let me know if they help, it would be much appreciated, thx.

Comment 14

7 years ago
I have tested the thunderbird-12.0.en-US.linux-i686.tar.bz2  version.
looks good:   no empty mails are created.
(In reply to Gabriella from comment #14)
> I have tested the thunderbird-12.0.en-US.linux-i686.tar.bz2  version.
> looks good:   no empty mails are created.

strange. I saw it in SeaMonkey 2.9a1 (MailNews Core 12.0a1) and I'm still seeing it in SeaMonkey 2.12a1 (MailNews Core 15.0a1) but only in my Movemail account:
- if /var/spool/mail/<username> is empty when I "Get Mail" for the Movemail account, an "empty" header (no Subject, no From, no To, date is 1970-01-01 00:00) appears in the threads pane.
- if /var/spool/mail/<username> is not empty, it is made empty and a single new header is added.
- "Right-click (on Movemail Inbox in Folders pane) → Properties → Repair folder → OK" always corrects the situation (removing the empty header, or making all new headers appear if there were more than one queued messages)

<username> above means root or nobody, depending on where cron jobs are configured to send their mail.
Mozilla/5.0 (X11; Linux x86_64; rv:15.0) Gecko/20120429 Firefox/15.0a1 SeaMonkey/2.12a1 ID:20120429003037

Fixing bug 748726 made this bug disappear => VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.