Last Comment Bug 713578 - java.lang.NullPointerException at org.mozilla.gecko.Tabs.closeTab(Tabs.java:147)
: java.lang.NullPointerException at org.mozilla.gecko.Tabs.closeTab(Tabs.java:147)
Status: RESOLVED FIXED
[native-crash]
: crash
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 11 Branch
: ARM Android
: -- critical (vote)
: Firefox 11
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-26 16:36 PST by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2016-07-29 14:21 PDT (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (954 bytes, patch)
2011-12-26 20:30 PST, Mark Finkle (:mfinkle) (use needinfo?)
blassey.bugs: review+
christian: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-26 16:36:46 PST
From Socorro : https://crash-stats.mozilla.com/report/index/a4eaa6c8-bae2-4fca-bae5-73e902111226
Build ID : 20111226031002

java.lang.NullPointerException
	at org.mozilla.gecko.Tabs.closeTab(Tabs.java:147)
	at org.mozilla.gecko.Tabs.closeTab(Tabs.java:139)
	at org.mozilla.gecko.TabsTray$TabsAdapter$2.onClick(TabsTray.java:179)
	at android.view.View.performClick(View.java:3117)
	at android.view.View$PerformClick.run(View.java:11941)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at org.mozilla.gecko.GeckoApp$33.run(GeckoApp.java:1517)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:132)
	at android.app.ActivityThread.main(ActivityThread.java:4123)
	at java.lang.reflect.Method.invokeNative(Native Method)

On Asus Transformer
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 20:30:00 PST
Created attachment 584373 [details] [diff] [review]
patch

I can't reproduce the crash, but the line seems to suggest "nextTab" is null. We already protect against a null "tab" so this patch adds a check for the "nextTab" too.

http://mxr.mozilla.org/mozilla-central/source/mobile/android/base/Tabs.java#147
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 22:15:36 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/ca8dca9419fc
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-26 22:40:51 PST
Comment on attachment 584373 [details] [diff] [review]
patch

crash fix for aurora
Comment 4 Matt Brubeck (:mbrubeck) 2011-12-27 11:09:16 PST
https://hg.mozilla.org/mozilla-central/rev/ca8dca9419fc
Comment 5 christian 2011-12-27 14:47:50 PST
Comment on attachment 584373 [details] [diff] [review]
patch

[triage comment]
Approved for aurora. Mobile only, crash fix, simple null check.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-27 22:28:31 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/0fa0c1451040

Note You need to log in before you can comment on or make changes to this bug.