Closed Bug 713592 Opened 11 years ago Closed 7 years ago

Crash in _moz_pixman_image_composite32

Categories

(Core :: Graphics, defect)

14 Branch
ARM
Android
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: nhirata, Unassigned)

References

Details

(Keywords: crash, Whiteboard: [mobile-crash])

Crash Data

buildsd ID	20111224031026

From Socorro:
https://crash-stats.mozilla.com/report/index/5a0fbc81-7ea8-4af7-883f-f5ff12111225

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	libxul.so 	_moz_pixman_image_composite32 	gfx/cairo/libpixman/src/pixman.c:518
1 	libxul.so 	_clip_and_composite_boxes 	gfx/cairo/cairo/src/cairo-image-surface.c:3002
2 	libxul.so 	_cairo_image_surface_fill 	gfx/cairo/cairo/src/cairo-image-surface.c:3759
3 	libxul.so 	_cairo_surface_fill 	gfx/cairo/cairo/src/cairo-surface.c:2348
4 	libxul.so 	_cairo_gstate_fill 	gfx/cairo/cairo/src/cairo-gstate.c:1290
5 	libxul.so 	_moz_cairo_fill_preserve 	gfx/cairo/cairo/src/cairo.c:2459
6 	libxul.so 	gfxContext::Fill 	gfx/thebes/gfxContext.cpp:160
7 	libxul.so 	mozilla::layers::ThebesLayerBuffer::DrawBufferQuadrant 	gfx/layers/ThebesLayerBuffer.cpp:111
8 	libxul.so 	mozilla::layers::ThebesLayerBuffer::DrawBufferWithRotation 	gfx/layers/ThebesLayerBuffer.cpp:123
9 	libxul.so 	mozilla::layers::ThebesLayerBuffer::BeginPaint 	gfx/layers/ThebesLayerBuffer.cpp:291
10 	libxul.so 	mozilla::layers::BasicThebesLayer::PaintThebes 	gfx/layers/basic/BasicLayers.cpp:732
11 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1896
12 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1911
13 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1911
14 	libxul.so 	mozilla::layers::BasicLayerManager::PaintLayer 	gfx/layers/basic/BasicLayers.cpp:1911
15 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransactionInternal 	gfx/layers/basic/BasicLayers.cpp:1608
16 	libxul.so 	mozilla::layers::BasicLayerManager::EndTransaction 	gfx/layers/basic/BasicLayers.cpp:1559
17 	libxul.so 	mozilla::layers::BasicShadowLayerManager::EndTransaction 	gfx/layers/basic/BasicLayers.cpp:3322
18 	libxul.so 	nsDisplayList::PaintForFrame 	layout/base/nsDisplayList.cpp:635
19 	libxul.so 	nsDisplayList::PaintRoot 	layout/base/nsDisplayList.cpp:540
20 	libxul.so 	nsLayoutUtils::PaintFrame 	layout/base/nsLayoutUtils.cpp:1701
21 	libxul.so 	PresShell::Paint 	layout/base/nsPresShell.cpp:5504
22 	libxul.so 	nsViewManager::RenderViews 	view/src/nsViewManager.cpp:418
23 	libxul.so 	nsViewManager::Refresh 	view/src/nsViewManager.cpp:393
24 	libxul.so 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:891
25 	libxul.so 	HandleEvent 	view/src/nsView.cpp:159
26 	libxul.so 	nsWindow::DispatchEvent 	widget/src/android/nsWindow.cpp:728
27 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1090
28 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1137
29 	libxul.so 	nsWindow::DrawTo 	widget/src/android/nsWindow.cpp:1051
30 	libxul.so 	nsWindow::OnDraw 	widget/src/android/nsWindow.cpp:1205
31 	libxul.so 	nsWindow::OnGlobalAndroidEvent 	widget/src/android/nsWindow.cpp:981
32 	libxul.so 	nsAppShell::ProcessNextNativeEvent 	widget/src/android/nsAppShell.cpp:449
33 	libxul.so 	nsBaseAppShell::DoProcessNextNativeEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:171
34 	libxul.so 	nsBaseAppShell::OnProcessNextEvent 	widget/src/xpwidgets/nsBaseAppShell.cpp:306
35 	libxul.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:622
36 	libxul.so 	NS_ProcessNextEvent_P 	obj-firefox/xpcom/build/nsThreadUtils.cpp:245
37 	libxul.so 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
38 	libxul.so 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:208
39 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:201
40 	libxul.so 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:189
41 	libxul.so 	nsAppStartup::Run 	toolkit/components/startup/nsAppStartup.cpp:220
42 	libxul.so 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3524
43 	libxul.so 	Java_org_mozilla_gecko_GeckoAppShell_nativeRun 	toolkit/xre/nsAndroidStartup.cpp:103
44 	libmozutils.so 	Java_org_mozilla_gecko_GeckoAppShell_onChangeNetworkLinkStatus 	other-licenses/android/APKOpen.cpp:295
45 	libdvm.so 	dvmPlatformInvoke 	
46 	libdvm.so 	dvmCallJNIMethod_general 	
47 	libdvm.so 	dvmResolveNativeMethod 	
48 	libdvm.so 	dvmAsmSisterStart 	
49 	libdvm.so 	dvmMterpStd 	
50 	libdvm.so 	dvmInterpret 	
51 	libdvm.so 	dvmCallMethodV 	
52 	libdvm.so 	dvmCallMethod 	
53 	libdvm.so 	dvmDetachCurrentThread 	
54 	libc.so 	__thread_entry 	
55 	libc.so 	pthread_create 	

Last Fix: bug 672787 : 2011-09-21 18:17:40 PDT
Keywords: crash
Whiteboard: [native-crash]
Duplicate of this bug: 715957
Dupe of bug 711852?
Severity: normal → critical
Summary: Regression: [@ _moz_pixman_image_composite32 ] → Crash [@ _moz_pixman_image_composite32 ]
Whiteboard: [native-crash] → [native-crash][mobile-crash]
There are crashes in XUL Fennec 14.0b6: https://crash-stats.mozilla.com/report/list?signature=libxul.so%400xb4db90+|+_moz_pixman_image_composite32
Status: RESOLVED → REOPENED
Crash Signature: [@ _moz_pixman_image_composite32 ] → [@ _moz_pixman_image_composite32 ] [@ libxul.so@0xb4db90 | _moz_pixman_image_composite32]
Resolution: WORKSFORME → ---
Summary: Crash [@ _moz_pixman_image_composite32 ] → Crash in _moz_pixman_image_composite32
Whiteboard: [native-crash][mobile-crash] → [mobile-crash]
Version: 12 Branch → 14 Branch
No recent crashes here
Status: REOPENED → RESOLVED
Closed: 11 years ago7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.