Many fonts fail to render ∪ glyph

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
6 years ago
a year ago

People

(Reporter: english_zinke, Unassigned)

Tracking

({regression})

9 Branch
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML, like Gecko) Chrome/16.0.912.63 Safari/535.7

Steps to reproduce:

Go to http://en.wikipedia.org/wiki/Union_%28set_theory%29#Algebraic_properties


Actual results:

It should render A ∪ (B ∪ C) = (A ∪ B) ∪ C

With many fonts (including the default Arial font), the union glyph ∪ is not rendered at all.  It is simply blank.  The intersection glyph ∩ shows up fine.  The union glyph shows up when I switch to Lucida Sans Unicode.  But i shouldn't have to switch fonts because all of this was working in Firefox until recently.  This glyph shows up fine in Chrome 16 and in Internet Explorer 8 with Arial font.  It fails in Firefox 8 and 9.
Component: General → Untriaged
QA Contact: general → untriaged

Comment 1

6 years ago
Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
works here on XP
Component: Untriaged → Layout: Text
Product: Firefox → Core
QA Contact: untriaged → layout.fonts-and-text
Version: 8 Branch → 9 Branch

Updated

6 years ago
Keywords: regression
(In reply to english_zinke from comment #0)
> User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/535.7 (KHTML,
> like Gecko) Chrome/16.0.912.63 Safari/535.7
> 
> Steps to reproduce:
> 
> Go to
> http://en.wikipedia.org/wiki/Union_%28set_theory%29#Algebraic_properties
> 
> 
> Actual results:
> 
> It should render A ∪ (B ∪ C) = (A ∪ B) ∪ C
> 
> With many fonts (including the default Arial font), the union glyph ∪ is not
> rendered at all.  It is simply blank.  The intersection glyph ∩ shows up
> fine.  The union glyph shows up when I switch to Lucida Sans Unicode.  But i
> shouldn't have to switch fonts because all of this was working in Firefox
> until recently.  This glyph shows up fine in Chrome 16 and in Internet
> Explorer 8 with Arial font.  It fails in Firefox 8 and 9.

I don't think Arial includes this character; therefore, the browser has to find an alternative (fallback) font. My guess is that you have a font installed that claims to support the character ∪, but actually has a blank glyph at that position, and that happens to be the font Firefox is choosing.

You can use the fontinfo add-on[1] to check what font(s) are being used for the text in question; select the range of text and choose Show Fonts in Selection from the right-click menu.

[1] https://addons.mozilla.org/en-US/firefox/addon/fontinfo/
(Reporter)

Comment 3

6 years ago
Thank you for pointing me to the fontinfo add-on.  The font is called kor_boot which was pre-installed (along with several others including chs_boot, jp_boot) on my Lenovo laptop as part of Lenovo's OneKey application.  I deleted these fonts and now Firefox chooses another font which correctly renders the glyph.  Thank you.
Firefox: 45.0,Build ID: 20160303134406
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Hi,

I have tested this issue on the latest Firefox (45.0)release, latest Nightly (48.0a1 - 20160308030418) build, and I could not reproduce it. The union glyph "∪" is concretely rendered.

Considering this, and based on comment 3 where it seems that the reporter could not reproduce the problem anymore, I will close this issue as Resolved - WFM. If anyone can still reproduce it, feel free to reopen the issue and provide more information.

Thanks,
Cosmin.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.