Last Comment Bug 713873 - crash in nsMsgDatabase::SetSummaryValid if feed db out of date
: crash in nsMsgDatabase::SetSummaryValid if feed db out of date
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Database (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Thunderbird 12.0
Assigned To: David :Bienvenu
:
:
Mentors:
Depends on:
Blocks: 402392
  Show dependency treegraph
 
Reported: 2011-12-28 08:33 PST by David :Bienvenu
Modified: 2012-02-07 16:45 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (779 bytes, patch)
2011-12-28 08:33 PST, David :Bienvenu
neil: review+
Details | Diff | Splinter Review

Description David :Bienvenu 2011-12-28 08:33:34 PST
Created attachment 584578 [details] [diff] [review]
proposed fix

If a feed database is out of date, we crash trying to download new messages in nsMsgDatabase::SetSummaryValid() because of a null m_dbFolderInfo.

I checked prior to the pluggable store landing and we checked for a null m_dbFolderInfo.
Comment 1 neil@parkwaycc.co.uk 2011-12-28 13:44:03 PST
Comment on attachment 584578 [details] [diff] [review]
proposed fix

Well, nsMailDatabase::SetSummaryValid certainly null-checks m_dbFolderInfo... nsMsgDatabase::SetSummaryValid never used to, but presumably we're passing it true which it used to ignore completely.
Comment 2 David :Bienvenu 2011-12-28 15:08:38 PST
fixed on trunk http://hg.mozilla.org/comm-central/rev/349840cd946a

Note You need to log in before you can comment on or make changes to this bug.